• Version 1.8.23 is triggering a fatal error in PHP 7.3.14:

    PHP Fatal error:  Uncaught Error: Object of class stdClass could not be converted to string in /var/www/html/***/wp-content/plugins/sucuri-scanner/src/base.lib.php:870
    Stack trace:
    #0 /var/www/html/***/wp-content/plugins/sucuri-scanner/src/base.lib.php(870): implode()
    #1 /var/www/html/***/wp-content/plugins/sucuri-scanner/src/event.lib.php(123): SucuriScan::implode()
    #2 /var/www/html/***/wp-content/plugins/sucuri-scanner/src/globals.php(83): SucuriScanEvent::activeSchedules()
    #3 /var/www/html/***/wp-content/plugins/sucuri-scanner/sucuri.php(248): require_once('/var/www/html/s...')
    #4 /var/www/html/***/wp-settings.php(360): include_once('/var/www/html/s...')
    # in /var/www/html/***/wp-content/plugins/sucuri-scanner/src/base.lib.php on line 870
Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi,

    We are experiencing this same error and it brought our site down last night. Are there any updates on this issue? We’ve had to disable Sucuri until this is resolved. 1.8.22 worked fine and now 1.8.23 broke our site.

    Thanks!

    Plugin Author imgersonr

    (@imgersonr)

    Thank you for the report, we are currently investigating and will let you know what we find.

    Plugin Author imgersonr

    (@imgersonr)

    I tried to replicate this issue with the information given and was unable to do so.

    Would it be possible to disable all plugins but version 1.8.23 of our plugin to make sure is not a conflict between plugins?

    I know this is probably redundant, but please make sure everything is up to date on your site (plugins, even WordPress itself).

    Plugin Author imgersonr

    (@imgersonr)

    Version 1.8.24 is out and should fix this issue. 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘PHP Fatal Error in 1.8.23’ is closed to new replies.