Support » Plugin: BackWPup - WordPress Backup Plugin » PHP Fatal error: Cannot redeclare getallheaders()

  • benoitfouc

    (@benoitfouc)


    Hello, after i’ve upgrade my website to php 7.3, backwpup was in error :
    [09-Oct-2019 19:33:00 UTC] PHP Fatal error: Cannot redeclare getallheaders() in /home/httpd/b/e/n/benfou/www.benfou.fr/wp-content/plugins/backwpup/vendor/ralouphie/getallheaders/src/getallheaders.php on line 10

    I was disable it, and if i try to enable it again i’ve this error and i can’t activate it.

    I’ve the same error after upgrade to php 7.3 with an other plugin (WpCerber) : https://wordpress.org/support/topic/fatal-error-after-php-version-update/

    • This topic was modified 10 months ago by benoitfouc.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Hello, this error still here today in 3 of my websites.

    Wp-Cerber have resolved this issue for Wp-cerber plugin, so now it’s only backwpup who is affected by this error. I can’t enable the plugin.

    Plugin Support duongcuong96

    (@duongcuong96)

    Hi @benoitfouc
    hmm I upgrade to PHP 7.3 and also using BackWPUp with WP-ceber and all works. So could you please list all currently activated plugins to me? I just need plugin name.
    also, please give me server info by going to BackWPUp -> Settings -> Info.
    Thank you!

    Hello 🙂

    Like i say : i can’t enable the plgin cause of this error 🙁

    BUT by DELETE the file /wp-content/plugins/backwpup/vendor/ralouphie/getallheaders/src/getallheaders.php
    i’ve activate the plugin.

    This is the debug informations :

    Version WordPress : 5.2.4
    Version BackWPup: 3.6.10
    Version PHP: 7.3.8  (64bit)
    Version MySQL: 10.2.26-MariaDB-10.2.26+maria~stretch
    Version cURL: 7.52.1
    Version SSL cURL: OpenSSL/1.0.2s
    URL WP-Cron: https://www.benfou.fr/wp-cron.php
    Connexion au serveur: Réponse HTTP non attendue :
    Code d’état : 200
    Server: nginx
    Date: Sat, 19 Oct 2019 09:15:13 GMT
    Content-type: text/html; charset=UTF-8
    X-powered-by: PHP/7.3.8
    Vary: FRONT-END-HTTPS
    Cache-control: max-age=259200
    Expires: Tue, 22 Oct 2019 09:15:13 GMT
    Set-cookie: SRVNAME=WEB3; path=/
    Content-encoding: gzip
    
    Document root: /home/httpd/b/e/n/benfou/www.benfou.fr/
    Dossier temporaire: /home/httpd/b/e/n/benfou/www.benfou.fr/wp-content/uploads/backwpup-bbfd29-temp/
    Dossier des fichiers journaux: /home/httpd/b/e/n/benfou/www.benfou.fr/wp-content/uploads/backwpup-bbfd29-logs/
    Serveur: Apache/2.4.41 (Unix) mod_fastcgi/mod_fastcgi-SNAP-0910052141
    Systùme d’exploitation: Linux
    PHP SAPI: fpm-fcgi
    Utilisateur PHP actuel: benfou
    Temps maximum d’exĂ©cution: 360 secondes
    Temps maximum d’exĂ©cution d’un script de BackWPup: 30 secondes
    WP Cron alternatif: Off
    WP Cron désactivé: Off
    CHMOD Dir: 493
    Heure du serveur: 9:15
    Heure du site web: 11:15
    Fuseau horaire du site web: Europe/Paris
    DĂ©calage temps avec le site web: 2 heures
    Langue du site: fr-FR
    Type d’encodage du client MySql: utf8mb4
    Limite mémoire de PHP: 256M
    Limite mémoire de WP: 256M
    Limite mémoire maximum de WP: 256M
    Mémoire utilisée: 26,00 MB
    Fonctions PHP désactivées :: dl passthru system eval shell_exec pcntl_exec popen exec proc_open pcntl_exe chroot virtual link getallheaders syslog opcache_reset opcache_invalidate opcache_get_status posix_kill posix_mkfifo posix_getpwuid posix_getgrgid posix_getpwuid posix_setpgid posix_setsid posix_setuid
    Extension PHP chargées :: Core, PDO, Phar, Reflection, SPL, SimpleXML, Zend OPcache, bcmath, bz2, calendar, cgi-fcgi, ctype, curl, date, dom, exif, fileinfo, filter, ftp, gd, gettext, gnupg, hash, iconv, imagick, imap, intl, ionCube Loader, json, libxml, mbstring, memcached, mysqli, mysqlnd, odbc, openssl, pcre, pdo_mysql, pdo_sqlite, session, soap, sockets, sqlite3, standard, sysvsem, tidy, tokenizer, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, zlib
    

    And i’ve these plugins installed :
    Akismet Anti-Spam
    BackWPup
    CF7 Invisible reCAPTCHA
    Contact Form 7
    Cookie Notice
    Jetpack par WordPress.com
    MainWP Child
    Salient Core
    Salient Portfolio
    Salient Shortcodes
    Salient WPBakery Page Builder
    Support Benfou (custom plugin)
    TinyMCE Advanced
    WP Cerber Security, Antispam & Malware Scan (last version 8.5, with the fix of this same issue !)
    WP Super Cache (disabled)
    Yoast SEO

    Hello, issue still here. I can’t enable the plugin, any fix ?

    Plugin Support duongcuong96

    (@duongcuong96)

    Hi @benoitfouc
    please update to 3.7, is that helps?
    Thank you!

    benoitfouc

    (@benoitfouc)

    No, same issue :
    WordPress version 5.3.2
    ThĂšme actuel : Nisarg (version 1.2.8.2)
    Extension actuelle : BackWPup (version 3.7.0)
    PHP version 7.3.13

    DĂ©tails de l’erreur
    ======================
    Une erreur de type E_ERROR a Ă©tĂ© causĂ©e dans la ligne 10 du fichier /home/httpd/b/e/n/benfou/www.benfou-serveur.fr/wp-content/plugins/backwpup/vendor/ralouphie/getallheaders/src/getallheaders.php. Message d’erreur : Cannot redeclare getallheaders()

    Hello this error still here in backwpup plugin BUT i’ts fixed in WP cerber plugin.

    Hello, WP Cerber support for developper say :
    “change the name of the function “getallheaders” and it can work”.
    That’s true, in wp-ontent/plugins/backwpup/vendor/ralouphie/getallheaders/src/getallheaders.phh i’ve change

    “function getallheaders()”
    by “function backwp_getallheaders()”

    And now i can activate the plugin.

    Can you add this fix in the next version please ?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘PHP Fatal error: Cannot redeclare getallheaders()’ is closed to new replies.