Support » Plugin: Pixel Caffeine » PHP Fatal error: Call to undefined method GuzzleHttp\Promise\Coroutine::of()

  • Resolved wildewebmarketing

    (@wildewebmarketing)


    The most recent update just put a stranglehold on my Easy Digital Downloads, throwing the following error whenever someone tries to download a fie:

    PHP Fatal error: Uncaught Error: Call to undefined method GuzzleHttp\Promise\Coroutine::of()

    Disabling Pixel Caffeine resolves the issue.

    Please advise.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Thread Starter wildewebmarketing

    (@wildewebmarketing)

    I reverted back to 2.1.4 and everything works again.

    Please advise so I can update to new version.

    Plugin Author Antonino Scarfì

    (@antoscarface)

    Hi,

    I cannot reproduce your issue because it seems to work well on my end 🙁

    Are you able to share more info about the error? If this errors comes up from the “Logs” tab of Pixel Caffeine, please share the report log. Otherwise, please activate the debug mode in your WordPress installation (more info https://codex.wordpress.org/Debugging_in_WordPress) and try to refresh the page. Then paste here the error code will appear, including file and line, so I can understand the reason of the issue and try to find a solution.

    Let me know.

    israelj

    (@israelj)

    I’m getting a conflict as well with another plugin. Maybe this will help? I’ve contacted the other plugin developer on their WP forum as well, but it seems there’s a conflict between Pixel Caffeine plugin and other plugins that utilize Guzzle.

    My sites that are using Pixel Caffeine 2.1.4 are not conflicting with this other plugin.

    Other Plugin Support Reference: https://wordpress.org/support/topic/php-fatal-error-guzzlehttp/

    Pixel Caffeine 2.2.0
    CF7 Google Sheets Connector Version 4.6
    WordPress Version 5.6.1
    PHP 7.4

    NOTICE: PHP message: PHP Fatal error: Uncaught Error: Call to undefined method GuzzleHttp\Utils::chooseHandler() in /www/wp-content/plugins/cf7-google-sheets-connector/lib/vendor/guzzlehttp/guzzle/src/functions.php:61

    [11-Feb-2021 17:53:35] WARNING: child 114 said into stderr: "Stack trace:"
    [11-Feb-2021 17:53:35] WARNING: child 114 said into stderr: "#0 /www/wp-content/plugins/pixel-caffeine/vendor/guzzlehttp/guzzle/src/HandlerStack.php(42): GuzzleHttp\choose_handler()"
    [11-Feb-2021 17:53:35] WARNING: child 114 said into stderr: "#1 /www/wp-content/plugins/pixel-caffeine/vendor/guzzlehttp/guzzle/src/Client.php(65): GuzzleHttp\HandlerStack::create()"
    [11-Feb-2021 17:53:35] WARNING: child 114 said into stderr: "#2 /www/wp-content/plugins/cf7-google-sheets-connector/lib/src/Client.php(1190): GuzzleHttp\Client->__construct(Array)"
    [11-Feb-2021 17:53:35] WARNING: child 114 said into stderr: "#3 /www/wp-content/plugins/cf7-google-sheets-connector/lib/src/Client.php(1143): Google\Client->createDefaultHttpClient()"
    [11-Feb-2021 17:53:35] WARNING: child 114 said into stderr: "#4 /www/wp-content/plugins/cf7-google-sheets-connector/lib/src/Client.php(333): Google\Client->getHttpClient()"
    [11-Feb-2021 17:53:35] WARNING: child 114 said into stderr: "#5 /www/wp-content/plugins/cf7-google-sheets-connector/lib/src/Client.php(311): Google\Client->fetchAccessTokenWithRefreshToken('...
    • This reply was modified 4 months ago by israelj.
    musicman847

    (@musicman847)

    Hi guys – I’m also getting this fatal error – A conflict with Easy Digital Downloads, the Amazon S3 Extension of EDD. Reverting to 2.1.4 fixes it for me as well. Here’s the error:

    [13-Feb-2021 19:08:35 UTC] PHP Fatal error: Uncaught Error: Call to undefined method GuzzleHttp\Promise\Coroutine::of() in /home/mysite/public_html/wp-content/plugins/pixel-caffeine/vendor/guzzlehttp/promises/src/functions.php:362
    Stack trace:
    #0 /home/mysite/public_html/wp-content/plugins/edd-amazon-s3/vendor/aws/aws-sdk-php/src/S3/S3MultiRegionClient.php(256): GuzzleHttp\Promise\coroutine(Object(Closure))
    #1 /home/mysite/public_html/wp-content/plugins/edd-amazon-s3/vendor/aws/aws-sdk-php/src/AwsClientTrait.php(65): Aws\S3\S3MultiRegionClient->Aws\S3\{closure}(Object(Aws\Command))
    #2 /home/mysite/public_html/wp-content/plugins/edd-amazon-s3/vendor/aws/aws-sdk-php/src/AwsClientTrait.php(59): Aws\MultiRegionClient->executeAsync(Object(Aws\Command))
    #3 /home/mysite/public_html/wp-content/plugins/edd-amazon-s3/vendor/aws/aws-sdk-php/src/AwsClientTrait.php(78): Aws\MultiRegionClient->execute(Object(Aws\Command))
    #4 /home/mysite/public_html/wp-content/plugins/edd-amazon-s3/class-edd-amazon-s3.php(569): Aws\MultiRegionClient->__call(‘listBuckets’ in /home/mysite/public_html/wp-content/plugins/pixel-caffeine/vendor/guzzlehttp/promises/src/functions.php on line 362

    Thread Starter wildewebmarketing

    (@wildewebmarketing)

    @musicman847 Yup, that’s where my issue lies as well.

    @antoscarface It’s definitely a conflict between two plugins using GuzzleHTTP. In my case and @musicman847 it’s EDD Amazon S3. With @israelj it’s CF7 Google Sheets Connector.

    @antoscarface I understand you can’t reproduce the issue. Can you at least offer some guidance how two plugins using GuzzleHTTP might cause this issue? What changed with GuzzleHTTP since 2.1.4? Because both plugins work together with this version.

    Plugin Author Antonino Scarfì

    (@antoscarface)

    Thank you guys, your info was very helpful.

    Yes, the reason is a conflict with the Guzzle library used by other plugins (excluded EDD itself) which gives a fatal error. I introduced this library in Pixel Caffeine in 2.2.0 and I’m unfortunately using a little bit older version of that library because I’m still keeping PHP 5.6 as a minimum requirement, but I need PHP 7.2+ to install the latest one (as CF7 Google Sheets Connector already does).

    Because even WordPress has finally changed its minimum requirement as well (https://wordpress.org/about/requirements/), I’ll stop supporting PHP <7.2, so I can use the latest dependency versions and also I can avoid keeping vulnerable versions of them.

    Thanks for the feedback and very sorry for the issue, I’ll update this as soon as possible (hopefully within this week).

    Thread Starter wildewebmarketing

    (@wildewebmarketing)

    @antoscarface Awesome thank you, Antonino!

    Thread Starter wildewebmarketing

    (@wildewebmarketing)

    Problem persists with 2.3.0.

    I’m also experiencing the fatal error:

    Fatal error: Uncaught Error: Undefined class constant 'MAJOR_VERSION' in /home/292293.cloudwaysapps.com/xgqayzdmur/public_html/wp-content/plugins/pixel-caffeine/vendor/guzzlehttp/guzzle/src/Utils.php:118 Stack trace: #0 /home/292293.cloudwaysapps.com/xgqayzdmur/public_html/wp-content/plugins/pixel-caffeine/vendor/guzzlehttp/guzzle/src/functions.php(71): GuzzleHttp\Utils::defaultUserAgent() #1 /home/292293.cloudwaysapps.com/xgqayzdmur/public_html/wp-content/plugins/gmail-smtp/google-api-php-client/vendor/guzzlehttp/guzzle/src/Client.php(194): GuzzleHttp\default_user_agent() #2 /home/292293.cloudwaysapps.com/xgqayzdmur/public_html/wp-content/plugins/gmail-smtp/google-api-php-client/vendor/guzzlehttp/guzzle/src/Client.php(75): GuzzleHttp\Client->configureDefaults(Array) #3 /home/292293.cloudwaysapps.com/xgqayzdmur/public_html/wp-content/plugins/gmail-smtp/google-api-php-client/src/Google/Client.php(1058): GuzzleHttp\Client->__construct(Array) #4 /home/292293.cloudwaysapps.com/xgqayzdmur/public_html/wp-content/plugins/gmail-s in /home/292293.cloudwaysapps.com/xgqayzdmur/public_html/wp-content/plugins/pixel-caffeine/vendor/guzzlehttp/guzzle/src/Utils.php on line 118
    
    There has been a critical error on this website.

    Any ETA on that update?

    Thread Starter wildewebmarketing

    (@wildewebmarketing)

    @antoscarface your support page is becoming littered with the Guzzle problem. Please at least provide a response so everyone knows this is being looked at.

    Is this fixable? By adding namespaces? What would be the timeframe for this fix?

    Plugin Author Antonino Scarfì

    (@antoscarface)

    Hey guys,

    very sorry to hear the issue it’s not fixed yet!

    I get this out of the way and I scoped the entire plugin third-party libraries, so they won’t conflict with other plugins anymore (I really hope!) because of shared namespaces.

    I prepared the fixed version, but I’m not releasing it yet. Please, download the alpha version from the following link and upload it in your installation in order to fix the problem (it should fix I’m pretty sure). Download from here: https://www.dropbox.com/s/py8n0oov8jr53yc/pixel-caffeine.fix-guzzle.2.3.0.zip?dl=0

    Let me know if it solves your issue so I’ll release the new version.

    Again, really sorry for the issue and thank you very much for your patience!

    Plugin Author Antonino Scarfì

    (@antoscarface)

    Sorry here, if you downloaded it already and you’ve not tested it yet, please download it again from now because I made some other fixes related to this issue.

    I post again the link to ease: https://www.dropbox.com/s/py8n0oov8jr53yc/pixel-caffeine.fix-guzzle.2.3.0.zip?dl=0

    Thanks for your patience and your feedback!

    Thread Starter wildewebmarketing

    (@wildewebmarketing)

    @antoscarface I was a little nervous installing the fixed version as customers on my end instantly start submitting tickets LOL.

    But I worked up the courage and gave it a try, fingers crossed in one hand, lucky rabbits foot clenched in the other…and it worked!

    Thank you for the time you put into fixing this for us. I know first hand the headaches of maintaining code. It is very much appreciated!

    I had the same problem with the wp-stateless plugin and We did install this version and everything works well. Thanks so much for your help

    Hi,

    Just tested it and the problem appears to be fixed.

    Thanks,

    Rudi

Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.