Support » Plugin: jQuery Pin It Button for Images » PHP fatal error after recent update

  • Resolved Ryan Townley

    (@ryantown)


    The update released today caused my client’s site to become unresponsive with an HTTP ERROR 500 on the front end and this PHP error in the error log…

    PHP Fatal error: Call to a member function get_queried_object_id() on a non-object in /public_html/wp-includes/query.php on line 61

    Disabling the plugin manually brought the site back online.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Confirmed. Can we get a brown paper bag 2.2.4 release to revert this behavior? Or will we need to use the old version to get the plugin to work for now?

    Confirmed here as well. I loaded 2.2.0 this morning to get my client’s site back online, but just a bit ago it auto-updated to 2.2.3 with the PHP error again. Thoughts on a fix?

    Plugin Author mrsztuczkens

    (@mrsztuczkens)

    Hey @ryantown, @agathongroup, @bethanybeams,

    my best guess is that the issue is related to using an old version of PHP on servers that are running your websites. I’ve changed the sensitive parts of the code for backwards compatibility and released another update. Please update and let me know if it works properly.

    same here, with the newest update I get this error:

    Fatal error: Call to a member function get_queried_object_id() on null in xxxx/wp-includes/query.php on line 61

    PHP version 5.6.29

    Plugin 2.2.1 is working, version 2.2.3 and 2.2.4 result in this error message

    • This reply was modified 4 years, 7 months ago by csigncsign.
    • This reply was modified 4 years, 7 months ago by csigncsign.

    It breaks on 7.0.x as well.

    -TS

    Have seen this break on a bunch of my client’s sites too – all running under PHP 7.0

    Plugin Author mrsztuczkens

    (@mrsztuczkens)

    Hey @csigncsign, @techsurgeons, @cagsmith,

    thanks for letting me know the issue is still there. I’ve dug in and hopefully found what’s causing the issue. Just released another update. Please let me know if everything is back to normal.

    @mrsztuczkens

    thanks a lot, version 2.2.5 works now fine at my 2 sites with PHP 5.6.29.

    Thanks Marcin (@mrsztuczkens),

    It works great here, both on 5.6.x & 7.0.x.
    -TS

    Plugin Author mrsztuczkens

    (@mrsztuczkens)

    Closing this topic as the issue seems to be fixed.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘PHP fatal error after recent update’ is closed to new replies.