Support » Plugin: Google Analytics » PHP Fatal Error after plugin update (2.1.2 -> 2.1.3)

  • Resolved wp_user59

    (@wp_user59)


    Hello,

    I just update the google analytics 2 days ago and since then, my websites where the “Google Analytics” plugins is activated become blank.

    In the log error of PHP, i see that line many times :
    ” [Fri Apr 07 09:19:54 2017] [error] [client *.*.*.*] PHP Fatal error: Call to undefined function curl_version() in /var/www/wp-content/plugins/googleanalytics/tools/class-support-logging.php on line 148 ”

    My WordPress plateform run 1 414 websites with 6 471 users so i don’t have time to let the bug in place.

    Here is my server config :
    OS : Debian 7 (64Bits)
    Kernel : 3.2.81
    Apache : 2.2.22 (suPHP 0.7.1)
    MySQL : 5.5.54
    PHP : 5.4.45
    Curl : 7.26.0
    (I don’t have php5-curl install on the server, is it require now ?)

    If you need more informations, i’m open to talk in private for more details.

    Thanks for your time.

    Regards,

    Jean-Jacques.

Viewing 8 replies - 1 through 8 (of 8 total)
  • We have the same problem: 100 sites…

    Hello nethics,

    Because of this Fatal error, the only work around i find is to disabled the plugin…

    2 options here : having stats for blank pages or have running websites 😉

    I hope that the dev will react very soon !

    Regards,

    Hi @wp_user59 & @nethics,

    Thank you so much for reporting on this issue, we want to apologize for the difficulties we might have caused for your sites. I’ve let our engineering team know and they were able to deploy a fix. Can you test out the plugin here and confirm that it works?
    Download: https://cl.ly/jx2g

    Apologies again for the inconvenience, if you have any other questions do let us know!

    I tried but doesn’t work …
    here the error: https://www.dropbox.com/s/6cn6hnsiemmqfll/ga.jpg?dl=0

    Hello,

    I tried your patch and it works great for me !

    The if condition you add fix the problem.

    Thank you very much for that !

    I had test it on my test plateform and it’s ok.
    I wait that you release officially the 2.1.4 version on WordPress to reinstall the plugin on my prod plateform.

    Thank you for your work.

    Regards,

    @nethics : in my opinion, you miss somethings i guess.

    the error indicate that php don’t find the file.

    Here is the test method i used :
    1) remove the entire directory from ” wordpress/wp-content/plugins/googleanalytics/ ”
    2) copy the new directory
    /!\ be carefull, the zip is not great, you have to copy only the subdirectory /!\
    “googleanalytics/googleanalytics/”
    3) reload your admin interface and add once again the plugin.

    And work for me.

    Godd luck !

    Hello !

    Any news for a release of the version 2.1.4 ?

    Thanks for your time !

    I was using this plugin mainly because it was so simple. Just one setting – tracking code – and nothing else. Now, after update (that brought down whole website), it’s overbloated mess with UI issues… something from manual of “how to destroy perfect plugin”. 🙁

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘PHP Fatal Error after plugin update (2.1.2 -> 2.1.3)’ is closed to new replies.