Support » Plugin: WP REST Cache » PHP Fatal Error

  • Resolved hansgv

    (@hansgv)


    Installing this plugin renders my site inoperable. Here’s the error log entry:

    2019/11/16 23:18:50 [error] 17360#17360: *764 FastCGI sent in stderr: "PHP message: PHP Warning:  Use of undefined constant SECURE_AUTH_COOKIE - assumed 'SECURE_AUTH_COOKIE' (this will throw an Error in a future version of PHP) in /var/www/vhosts/mysite.com/wp-includes/pluggable.php on line 777PHP message: PHP Warning:  Use of undefined constant LOGGED_IN_COOKIE - assumed 'LOGGED_IN_COOKIE' (this will throw an Error in a future version of PHP) in /var/www/vhosts/mysite.com/wp-includes/user.php on line 347PHP message: PHP Warning:  include_once(/var/www/vhosts/mysite.com/wp-content/plugins/wp-rest-cache/wp-rest-cache.php): failed to open stream: No such file or directory in /var/www/vhosts/mysite.com/wp-content/mu-plugins/wp-rest-cache.php on line 25PHP message: PHP Warning:  include_once(): Failed opening '/var/www/vhosts/mysite.com/wp-content/plugins/wp-rest-cache/wp-rest-cache.php' for inclusion (include_path='.:/usr/share/php') in /var/www/vhosts/mysite.com/wp-content/mu-plugins/wp-rest-cache.php on line 25PHP message: PHP Fatal error:  Uncaught Error: Class 'WP_Rest_Cache_Plugin\Includes\API\Endpoint_Api' not found in /var/www/vhosts/mysite.com/wp-content/mu-plugins/wp-rest-cache.php:27
    Stack trace:
    #0 /var/www/vhosts/mysite.com/wp-settings.php(291): include_once()
    #1 /var/www/vhosts/mysite.com/wp-config.php(115): require_once('/var/www/vhosts...')
    #2 /var/www/vhosts/mysite.com/wp-load.php(37): require_once('/var/www/vhosts...')
    #3 /var/www/vhosts/mysite.com/wp-blog-header.php(13): require_once('/var/www/vhosts...')
    #4 /var/www/vhosts/mysite.com/index.php(17): require('/var/www/vhosts...')
    #5 {main}
      thrown in /var/www/vhosts/mysite.com/wp-content/mu-plugins/wp-rest-cache.php on line 27" while reading response header from upstream, client: 207.46.13.170, server: mysite.com, request: "GET /ruoka/himoitsetko-suklaata-korvaa-herkut-terveellisemmilla-vaihtoehdoilla/ HTTP/1.1", upstream: "fastcgi://unix:/run/php/php7.3-fpm.sock:", host: "mysite.com"
    
Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Richard Korthuis

    (@rockfire)

    Hi @hansgv

    Thank you for using our plugin!

    I am sorry to hear you are experiencing this error. I hav had a look at your error log and what I notice is the following line:
    PHP message: PHP Warning: include_once(/var/www/vhosts/mysite.com/wp-content/plugins/wp-rest-cache/wp-rest-cache.php): failed to open stream: No such file or directory in /var/www/vhosts/mysite.com/wp-content/mu-plugins/wp-rest-cache.php on line 25
    What it tells me is that the mu-plugin was successfully installed (in /var/www/vhosts/mysite.com/wp-content/mu-plugins/), but that it seems that the main plugin was not installed in /var/www/vhosts/mysite.com/wp-content/plugins/wp-rest-cache/. How did you install our plugin? And what did you do with it afterwards? Did you rename the plugin folder? And is your plugins folder indeed situated in /var/www/vhosts/mysite.com/wp-content/plugins/?

    Somehow the mu-plugin is there, WordPress is telling it that the wp-rest-cache plugin is in fact activated. But it cannot find the plugin files in the correct location.

    hansgv

    (@hansgv)

    That’s exactly what I was wondering, but both /var/www/vhosts/mysite.com/wp-content/plugins/wp-rest-cache/ and /var/www/vhosts/mysite.com/wp-content/mu-plugins/wp-rest-cache.php exist.

    I installed the plugin straight from WordPress’ plugin directory.

    I first suspected this to be a caching conflict but neither disabling W3TC caches nor deleting the plugin and reinstalling it helped.

    The first message after enabling the plugin and reloading any admin page is a WordPress error: “You do not have sufficient permissions to access this admin page.”

    • This reply was modified 3 months ago by hansgv.
    Plugin Author Richard Korthuis

    (@rockfire)

    This is really strange. I tried to reproduce your error, but when I deliberately change the mu-plugin so it cannot find the plugin files anymore I do not get the “You do not have sufficient permissions” error. Instead I get: “There has been a critical error on your website. Please check your site admin email inbox for instructions.”. Which is what you might expect, since the fatal error is thrown.

    May I ask which other plugins you have installed? It almost seems as if there is a conflict.

    hansgv

    (@hansgv)

    Yes, I have a bunch of plugins installed:

    
    admin-menu-editor
    artbees-captcha
    bloom
    broken-link-checker
    classic-editor
    custom-post-type-ui
    duplicate-post
    duracelltomi-google-tag-manager
    enhanced-media-library
    envato-market
    fontpress
    gravityforms
    gravityformsmailchimp
    gravityformsquiz
    heartbeat-control
    instagram-widget-by-wpzoom
    ithemes-security-pro
    js_composer_theme
    jupiter-donut
    just-tinymce-styles
    last-modified-timestamp
    loco-translate
    monarch
    our-own-custom-form
    our-own-gravity-slider-fields
    our-own-quiz-stats
    recaptcha-in-wp-comments-form
    redirection
    rename-media-files
    rvg-optimize-database
    safe-svg
    ultimate-category-excluder
    w3tc-custom
    w3-total-cache
    wb-paytrail-maksutavat
    widget-options
    woocommerce
    woocommerce-dynamic-pricing
    wordpress-seo
    wp-authorbox-posts
    wp-author-box-pro
    wp-category-permalink
    wp-crontrol
    wp-external-links
    wp-user-avatar
    yuzo
    
    • This reply was modified 3 months ago by hansgv.
    • This reply was modified 3 months ago by hansgv.
    • This reply was modified 3 months ago by hansgv.
    • This reply was modified 3 months ago by hansgv.
    Plugin Author Richard Korthuis

    (@rockfire)

    Hi @hansgv

    Thank you for the list, which is quite long… Unfortunately there are several paid plugins in your list, making it really hard for me to try to recreate your setup and trying to reproduce the error.

    The only thing left for me to advise you is to try deactivating all plugins and then reinstalling our plugin.

    I disabled all w3-total-cache caches, disabled all plugins except w3-total-cache and classic-editor, and reinstalled the wp-rest-cache plugin. The issue still persists. Unable to log in afterward.

    After deleting wp-rest-cache again, I’m able to log in and see this error message:

    WP REST Cache: We have detected you are using external object caching. If you are using Memcache(d) as external object cache, please make sure you visit this plugin's settings page and check the "Using Memcache(d)" checkbox.

    I do use memcached with w3-total-cache’s Page, Database and Object Caches.

    • This reply was modified 2 months, 3 weeks ago by hansgv.
    Plugin Author Richard Korthuis

    (@rockfire)

    Hi @hansgv

    You say: “After deleting wp-rest-cache again”, but you do get a notice from our plugin, so I don’t understand that part? What did you delete?

    About the notice: if you are indeed using W3TC with memcached and object caches, it is indeed advised to check the checkbox as mentioned in the message. This is because PHP’s memcached treats cache timeouts a little different and checking the checkbox will prevent any errors.

    You say: “After deleting wp-rest-cache again”, but you do get a notice from our plugin, so I don’t understand that part? What did you delete?

    I just meant that I have to delete the plugin to be able to log in again. That error message is visible at the first admin page load after deleting.

    Obviously I’m not able to check any settings boxes as the plugin has already had to be deleted. 🙂

    • This reply was modified 2 months, 3 weeks ago by hansgv.
    Plugin Author Richard Korthuis

    (@rockfire)

    What file(s) did you actually delete? Because if you deleted the plugin, you should also not be able to see that notice since it is coming from the plugin. So apparently you did not delete the plugin.

    (By the way: you keep referring to the notice as an error, but it isn’t an error. It is a (dismissable) notice to let you know about the settings)

    rm -R /var/www/vhosts/mysite.com/wp-content/plugins/wp-rest-cache/
    and
    rm /var/www/vhosts/mysite.com/wp-content/mu-plugins/wp-rest-cache.php

    That’s right, it’s not an error message. It might not even be relevant in any way. Just wanted to report everything that comes by.

    • This reply was modified 2 months, 3 weeks ago by hansgv.
    Plugin Author Richard Korthuis

    (@rockfire)

    Hi @hansgv

    Well, those are the correct deletions, but are they really deleted? Because IF they were indeed deleted you would not be able to see the notice anymore, since the plugin that shows the notice is gone.

    I think the probability of rm command failing silently is close to zero. 🙂

    Maybe the notice was just a cached item or something.

    I remain interested in your plugin and am happy to assist in debugging any way I can.

    Plugin Author Richard Korthuis

    (@rockfire)

    Unfortunately at this point I am unable to help you any further. I am unable to reproduce your error and from what you are telling me I don’t see anything wrong other than the fact that the must use plugin is unable to find the wp-rest-cache plugin.

    Plugin Author Richard Korthuis

    (@rockfire)

    This thread has been marked as resolved due to lack of activity.

    You’re always welcome to open a new topic.

    Thanks for understanding!

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.