WordPress.org

Support

PHP Fatal error

  • Hi, I woke up this morning and was recently locked out of one of my sites giving me a 500 internal error. I first tried removing the BWPS additions to the .htaccess file but that didn’t work. I had to get my webhost to look up the problem and they reported this error:

    PHP Fatal error: Maximum execution time of 30 seconds exceeded in /home/domain/public_html/domain.com/wp-content/plugins/better-wp-security/inc/filecheck.php on line 492

    and

    PHP Fatal error: Maximum execution time of 30 seconds exceeded in /home/domain/public_html/domain.com/wp-content/plugins/better-wp-security/inc/filecheck.php on line 488

    They had to chmod the plugin directory to disable it to get the site accessible again. Anything I can do to avoid this problem? If I just disable the “File Change Detection” option would this resolve this issue?

    Also is there a way to to return settings to default or at least turn off the file check by editing the plugin config somehow outside of wordpress? I cant get to the options because the plugin is disabled and if i re-enable it then I cant access the site at all.

    http://wordpress.org/extend/plugins/better-wp-security/

Viewing 3 replies - 1 through 3 (of 3 total)
  • i had to remove the file check table from my DB when one of my sites had this issue

    500 internal errors can happened if the website is trying to use more memory than its available.

    Choices you may have:
    – Don’t enable features in Better WP Security that you don’t need. Some of them require lots of memory, so far what I know are File Change Detection and Backup.
    – Don’t install too many plugins, use only what you really need.
    – Change to better webhost which give you more memory.

    If you’re now can’t access your website backend, you may need this information:
    http://wordpress.org/support/topic/after-log-in-screen-goes-blank

    I am facing the same issue. First I just got the fatal error message on activating the plugin. Then I increased the memory available. After that I started getting this error.

    How can I install the plugin without file check option? Alternatively how do I remove the file check table?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP Fatal error’ is closed to new replies.
Skip to toolbar