WordPress.org

Forums

PHP errors Wp-admin and Wp-includes on upgrade (5 posts)

  1. AlvinYap
    Member
    Posted 9 years ago #

    Hi all, I've been using WP since September and just a couple of hours ago, I upgraded from 1.5 to 2.0 - now I've got this error when I try to view my blog:

    Fatal error: Call to undefined function: is_user_logged_in() in /home/alvinyvo/public_html/wp-includes/classes.php on line 1566

    When I try to log in, I get this error:

    Warning: main(/home/alvinyvo/public_html/wp-includes/registration-functions.php): failed to open stream: No such file or directory in /home/alvinyvo/public_html/wp-admin/admin.php on line 12

    Fatal error: main(): Failed opening required '/home/alvinyvo/public_html/wp-includes/registration-functions.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/alvinyvo/public_html/wp-admin/admin.php on line 12

    1. I didn't erase the old WP files, I just overwrote them
    2. I didn't back up my index.php - I didn't back up anything, just overwrote them
    3. I am using Tiger-plugin for the interface

    Should I delete Wp-admin and Wp-includes folders and just upload again and should it be binary or ASCII?

    Could anyone please help me to work around this? I'm tempted to re-install but use my old Database (can I do that?) but I don't want to make it worse than it is.

    Thanks

  2. citeewurkor
    Member
    Posted 9 years ago #

    Man, I hate to say this, but did you read any of this?
    http://wordpress.org/support/topic/53208?replies=103

    Did you run the upgrade script?

  3. moshu
    Member
    Posted 9 years ago #

    http://wordpress.org/support/topic/54578?replies=1
    Double posting is considered bad manners :)

    1. That's a mistake, you can still do it.
    2. Too late, I guess.
    3. All the plugins are supposed to be deactivated before upgrade.

    All the WP files should be uploaded as ASCII.

    And the bonus response: on the main page of this forum there is a "sticky" post with red background. Read it!

  4. mattman
    Member
    Posted 9 years ago #

    Hum,

    That's unusual...Sorry I can't help more than that. I can point out though, make sure that you get the latest WP-Tiger admin interface plugin. The old one has conflicts - new admin features and all.

  5. AlvinYap
    Member
    Posted 9 years ago #

    Sorry for the double post and I guess I got caught by RFTM this time

Topic Closed

This topic has been closed to new replies.

About this Topic