Support » Plugin: Subscribe2 - Form, Email Subscribers & Newsletters » PHP errors with Subscribe2 v10.24

  • Hi.. updated to Subscribe2 v10.24 and am now seeing PHP errors when using page previews. One preview viewing generates maybe several errors with the same error message. See log below. To see the problem, I do the following:

    1. View PHP error log (I have Error Log Monitor installed) and note time of last error
    2. Open a page in edit mode
    3. Open page in Preview and then close the preview window
    4. View PHP error log again and see that a new set of errors has been recorded

    With all plugins deactivated except the essentials Error Log Monitor & Plugin Organiser I see no error if Subscribe2 is deactivated and I do get errors if Subscribe2 is activated.
    So even though the logged error does not mention Subscribe2 I suspect that is where the problem lies? I did not see errors before updating to this version.
    Can anyone shed light on this, please. Tony

    Sample error log entry:

    Apr 12, 18:14:52
    PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, class 'S2_Admin' does not have a method 's2_preview_handler' in /home/antipole/public_html/ovni-owners-test-site/wp-includes/class-wp-hook.php on line 288
Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP errors with Subscribe2 v10.24’ is closed to new replies.