Support » Plugin: === Social Share Icons & Social Share Buttons » PHP errors since update

  • Resolved webrightnow

    (@webrightnow)


    Hi, since the latest update I am getting PHP error messages in the admin:

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function ‘sfsi_checkmetas’ not found or invalid function name in /home/riservaaurea/public_html/wp-includes/class-wp-hook.php on line 286

    Warning: Cannot modify header information – headers already sent by (output started at /home/riservaaurea/public_html/wp-includes/class-wp-hook.php:286) in /home/riservaaurea/public_html/wp-includes/pluggable.php on line 1251

    Warning: Cannot modify header information – headers already sent by (output started at /home/riservaaurea/public_html/wp-includes/class-wp-hook.php:286) in /home/riservaaurea/public_html/wp-includes/pluggable.php on line 1254

    Warning: Cannot modify header information – headers already sent by (output started at /home/riservaaurea/public_html/wp-includes/class-wp-hook.php:286) in /home/riservaaurea/public_html/wp-admin/includes/misc.php on line 1198

    Errors disappear when disabling your plugin. On WP 5.1.1.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author socialdude

    (@socialdude)

    Thank you for reporting this, we’ve fixed it and will release it in the next version (which will be uploaded next week). For now, please select under question 6 to switch error reporting off (not dangerous), that should fix it for now.

    Great thanks, that worked, look forward to the update.

    Me too. Anxious for a fix ASAP. Thank you!

    Plugin Contributor socialtech

    (@socialtech)

    The new version with the fix is released. Please update and confirm the issue is gone.

    @ballou After update, please switch error reporting to “on” again.

    Yes, updated and re-enabled error reporting, no errors now. Thanks for fixing.

    Plugin Author socialdude

    (@socialdude)

    Great, thank you for your confirmation!

    Resolved for me too! Thanks.

    Hello, folks, sorry, it didn’t work for me. Actually the site is worst now, as you can see at links:

    http://www.flavitaconceicao.com.br

    and

    http://www.flavitaocnceicao.com.br/wp-admin

    I trusted at Ultimate Social Media Icons Plus Plugin and now I’m trouble.

    I’m a beginner at wordpress and my client is screaming at phone with me. If anyone could help, I would be thankful!

    Plugin Author socialdude

    (@socialdude)

    @brucecullen Those errors are not coming from our plugin – you can see that they are referring to your theme, not our plugin. You can still switch the error reporting in our plugin to “off” again, which may then also hide those errors, however they don’t come from our plugin.

    Thank you for your fast reply, The theme was working correctly before and just the wp-admin acces had a problem, exactly how webrightnow described, so I thought it could be your plugin problem.

    The issue at header appeared later.

    I’m trying to not delete all the site and start again but I guess I’m out of options now.

    Thank you anyway.

    • This reply was modified 1 month, 2 weeks ago by  brucecullen.
Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.