• Resolved terry777

    (@terry777)


    My site went down for awhile today, and the reason was that it’s running on php 7.2 and something is incompatible. They rolled it back to 7.1 so it’s working again, but I ran the PHP compatibility checker for versions 7.0, 7.1 and 7.2 and this plugin came up with 5 errors and 2 warnings on all. I don’t know if it was the plugin that caused the site to go down, as I’m not sure it’s actually being used, having been installed by someone else, but I thought you should know. It also has not been tested with WP 4.9.6 which we’re running now.

    If you let me know that you’ve corrected it, I’ll update it. Thanks.

    FILE: …/wp-content/plugins/videowhisper-live-streaming-integration/bp.php
    —————————————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————————————————
    14 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    —————————————————————————————————————————

    …/wp-content/plugins/videowhisper-live-streaming-integration/ls/incsan.php
    ———————————————————————————————————————————————
    FOUND 2 ERRORS AFFECTING 1 LINE
    ———————————————————————————————————————————————
    25 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    25 | ERROR | Function mysql_escape_string() is deprecated since PHP 5.3 and removed since PHP 7.0; Use mysqli::real_escape_string() instead
    ———————————————————————————————————————————————

    …/wp-content/plugins/videowhisper-live-streaming-integration/videowhisper_streaming.php
    ———————————————————————————————————————————————–
    FOUND 3 ERRORS AND 1 WARNING AFFECTING 4 LINES
    ———————————————————————————————————————————————–
    18 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    1724 | ERROR | Using ‘break’ outside of a loop or switch structure is invalid and will throw a fatal error since PHP 7.0
    6705 | ERROR | Using ‘break’ outside of a loop or switch structure is invalid and will throw a fatal error since PHP 7.0
    6828 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    ———————————————————————————————————————————————–

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author videowhisper

    (@videowhisper)

    Plugin was tested with WP 4.9+ and works fine.

    Latest version should also work fine with PHP 7+ .
    You can contact VideoWhisper staff from https://videowhisper.com/tickets_submit.php for specific errors and troubleshooting.

    What tool are you using to check compatibility (provide link)?
    Seems to report issues with break incorrectly, as break is used inside foreach loop around lines mentioned there.
    http://php.net/manual/en/control-structures.break.php
    (PHP 4, PHP 5, PHP 7)
    break ends execution of the current for, foreach, while, do-while or switch structure.

    PHP 7.1 is actively supported for 5 more months so you don’t need to upgrade to 7.2 until everything works fine http://php.net/supported-versions.php .

    terry777

    (@terry777)

    I used PHP Compatibility Checker 1.4.5 (https://wordpress.org/plugins/php-compatibility-checker/).

    They set PHP back to 7.1 for me, as the site would not load using 7.2. There was another plugin that gave a warning at 7.2 as well.

    While your plugin was installed, it was not actually being used on any page, so I deactivated it and deleted it, so I’m not going to take the effort to troubleshoot it. I just thought you should know there was a possibility of a problem.

    Plugin Author videowhisper

    (@videowhisper)

    Our demos run on PHP 7.2 fine so issue is probably related to other settings / modules.
    [ Signature moderated. ]

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Php errors and warning’ is closed to new replies.