Support » Plugin: Viper's Video Quicktags Migrator » PHP Errors

  • Resolved ThirstyJon

    (@thirstyjon)


    I’ve started getting php errors where old vipers video quicktag videos are on my site.

    Warning: Illegal string offset ‘src’ in /home/*topsecretnotgoingtotellyou*/public_html/domains/freedomthirst.com/wp-content/plugins/vipers-video-quicktags-migrator/vipers-video-quicktags-migrator.php on line 322

    I’m guessing the plugin just isn’t compatible with php 7.2?

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Contributor Alex Mills

    (@viper007bond)

    It’s not a PHP 7.2 issue, rather the plugin is looking for a src parameter in an old [flv] or [wmv] shortcode and the parameter doesn’t exist. The error is coming from my plugin trying to use the value without checking it actually exists.

    PHP warnings and notices are good to be fixed but aren’t true errors that need to be worried about usually.

    Can you figure out which post(s) are causing this warning and what the contents of the post are? I’m curious as to what shortcode content is causing it.

    I was scrolling through my old blog which has posts going all the way back to 2007.

    There were many posts where there was a php error instead of a video.

    I’ll scroll through again and find some of the shortcodes and post them back here.

    This one uses an flv tag: https://freedomthirst.com/2010/03/19/dangerous-posters-corrupting-our-children/

    As does this one: https://freedomthirst.com/2010/03/15/why-you-should-believe-in-evolution/

    Here is another one using an flv tag: https://freedomthirst.com/global-warming-co2-scam-video/

    Come to think of it, I often used flv tags back in the day.

    Plugin Contributor Alex Mills

    (@viper007bond)

    Can you edit the post and then post the shortcode you used here? I want to make sure I’m correctly parsing the old format you used.

    • This reply was modified 3 months, 3 weeks ago by  Alex Mills.

    I am not 100% sure what you are asking.

    This is how the tagged portion looks like:

    [flv]https://freedomthirst.com/wp-content/uploads/2010/03/dangerous_posters.flv[/flv]

    That is this post: https://freedomthirst.com/2010/03/19/dangerous-posters-corrupting-our-children/

    It is inside a table if that matters.

    Am I understanding what you are looking for?

    Plugin Contributor Alex Mills

    (@viper007bond)

    That’s exactly what I needed. I think my plugin was looking for something like this:

    [flv src="VIDEO_URL"]Some text or something?[/flv]

    I’ll make sure it can handle the format you’re using.

    Plugin Contributor Alex Mills

    (@viper007bond)

    Should be fixed in v1.2.1. Thanks for the report.

    👍

    Just in case this helps with that future release:

    I just had ANOTHER site with old content start to produce PHP errors on the home page.

    jondavisjr.com

    Here is the error message:

    src
    Warning: Cannot modify header information – headers already sent by (output started at /home/**SECRET**/public_html/domains/jondavisjr.com/wp-content/plugins/vipers-video-quicktags-migrator/vipers-video-quicktags-migrator.php:1) in /home/**SECRET**/public_html/domains/jondavisjr.com/wp-content/plugins/sg-cachepress/core/Supercacher/Supercacher_Helper.php on line 41

    I don’t have the skill level to interpret that, but I can see the names of vipers video quicktags migrator and my sg-cachepress plugin (which is a plugin provided by my hosting company).

    Yesterday I was unable to view my site or login at all until I accessed the site via ftp and changed the name of the vipers quicktag plugin thus deactivating it.

    When I changed the name back and reactivated vipers quicktag again in the wordpress dashboard I got this message on my wordpress dashboard:

    “The plugin generated 4 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.”

    I’m not sure if this is related to the same problem or not, but it is curious that it is happening about the same time as the problems on my freedomthirst.com site.

    I am deactivating the vipers video quicktags migrator plugin for now.

    Let me know if turning it back on will help you out in any way – but it does make my site show php errors, and in some cases ONLY php errors.

    I just saw that you upgraded the plugin.

    My site automatically did the upgrade (I have it setup that way).

    The problem on the jondavisjr.com site happened AFTER the upgrade – so it is a problem in the new version.

    Possibly related to Michael Visser’s post about “fsrc” being injected into the header.

    I do have version 1.2.1 on both freedomthirst.com and jondavisjr.com

    Yes, I’m also experiencing the “headers already sent by” php bug with 1.2.1.

    @tommcgee ‘s suggestion worked for this.

    I just went into the plugin file and deleted the 4 letters and the problem is solved. 🙂

    @zsero , see the one post in this forum that is newer than this one.

    And I also assume Alex will fix it.

    Blessings.

    Thanks, removing that works!

    Plugin Contributor Alex Mills

    (@viper007bond)

    Sorry about this. I’m visually impaired and completely missed the fact that I fat fingered in these extra characters. I’ll get a new version out ASAP!

    Plugin Contributor Alex Mills

    (@viper007bond)

    Fixed in v1.2.2!

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.