Support » Plugin: WooCommerce Cart Stock Reducer » PHP errors

  • Hi James,

    I’m seeing this error notice in the php logs. Any ideas what might be the root cause and how to fix it? Running the WC 3.5.1 and 2.10 version of your plugin.

    [10-Nov-2018 12:06:00 UTC] PHP Fatal error: Uncaught Exception: Invalid order. in /data/wordpress/htdocs/wp-content/plugins/woocommerce/includes/data-stores/abstract-wc-order-data-store-cpt.php:100
    Stack trace:
    #0 /data/wordpress/htdocs/wp-content/plugins/woocommerce/includes/class-wc-data-store.php(159): Abstract_WC_Order_Data_Store_CPT->read(Object(WC_Order))
    #1 /data/wordpress/htdocs/wp-content/plugins/woocommerce/includes/abstracts/abstract-wc-order.php(111): WC_Data_Store->read(Object(WC_Order))
    #2 /data/wordpress/htdocs/wp-content/plugins/woocommerce-cart-stock-reducer/includes/class-woocommerce-cart-stock-reducer.php(1109): WC_Abstract_Order->__construct(690391)
    #3 /data/wordpress/htdocs/wp-content/plugins/woocommerce-cart-stock-reducer/includes/class-wc-csr-sessions.php(127): WC_Cart_Stock_Reducer->is_expired(1541718278, 690391)
    #4 /data/wordpress/htdocs/wp-content/plugins/woocommerce-cart-stock-reducer/includes/class-woocommerce-cart-stock-reducer.php(1007): WC_CSR_Sessions->quantity_in_carts(689849, ‘product_id’, false)
    #5 /data/wordpress/ in /data/wordpress/htdocs/wp-content/plugins/woocommerce/includes/data-stores/abstract-wc-order-data-store-cpt.php on line 100

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author James Golovich

    (@jamesgol)

    I have not had a chance to test with WooCommerce 3.5.1 yet, I’ve been working on building a testing framework to hopefully identify these issues without having to manually test each version.

    When I have a chance I’ll test it out and see what I can figure out.

    Plugin Author James Golovich

    (@jamesgol)

    I’ve tried to reproduce this but haven’t been able to. Can you give some more specifics on how to reproduce it?

    BTW: Based on the filenames and line numbers you appear to be running the development version of the plugin and not 2.10.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.