Support » Plugin: Gravity Forms Entries in Excel » PHP error with latest version (1.7.0)

  • Resolved Esteban

    (@tcattd)


    As title says.

    This is the error i got: https://paste.ee/p/fNX8V
    Uncaught TypeError: Argument 1 passed to GFExcel\Action\FilterRequest::parseFilters() must be of the type string, array given, called in /home/nginx/*****/html/wp-content/plugins/gf-entries-in-excel/src/Action/FilterRequest.php on line 89 and defined in /home/nginx/*****/html/wp-content/plugins/gf-entries-in-excel/src/Action/FilterRequest.php:118

    And it was crashing the REST API jwt authentication for us because of that error.
    As soon as i disabled your plugin, the jwt authentication worked again.

    WP version: 5.2.4
    GF version: 2.4.14.8
    GF in Excel version: 1.7.0
    PHP version: 7.1.27

    Thanks in advance for the time and help 😉
    Esteban

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Doeke Norg

    (@doekenorg)

    Hi @tcattd,

    This looks like two plugins competing for the filter namespace in the query_vars. Please revert to 1.6.3 for the time being. I’ll scope the filter to my plugin a bit better.

    Thanks for letting me know. I’ll keep you updated on the fix.

    (You can download a previous version here: https://wordpress.org/plugins/gf-entries-in-excel/advanced/)

    Thanks for the suggestion.

    Will wait for the update.
    Thanks!

    Plugin Author Doeke Norg

    (@doekenorg)

    hi @tcattd,

    There doesn’t seem to be an issue directly between my plugin and the rest framework, or the JWT plugin. One of your other plugins is defining a filter array on the query_vars. It would help a lot if you could provide me with a list of your plugins so I can narrow down the issue, and perhaps solve it more elegant than I’m currently thinking.

    Please let me know.

    Sure,

    They are a lot: https://paste.ee/p/NCsqX

    Plugin Author Doeke Norg

    (@doekenorg)

    Wow @tcattd, that it is!

    I think it would be way faster for you to find out which one of your plugins is crashing with this one, than me. Would you be able to find that out, by activating 1.7.0 and one by one checking trying to disable a plugin? (maybe in a beta environment?)

    For now you seem to be the only one experiencing this issue. Although I have a small fix, that would mean that the filtering I build into 1.7.0 would not work for you. That would be a shame 🙂

    Please let me know if you are willing to test this for me. Thanks!

    Plugin Author Doeke Norg

    (@doekenorg)

    HI @tcattd ,

    I think this problem is solved in 1.7.1. Could you confirm this for me?

    Thanks in advance!

    Sorry for the delay replying.

    Yes, updated to 1.7.1 and the JWT auth with the REST API works without issues now.

    Thank you 😉

    • This reply was modified 2 months, 3 weeks ago by Esteban.
Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.