Support » Plugins and Hacks » Brightcove Video Connect » Php error when the plugin is installed

  • Hello,
    when we install plugin we have the following php error :
    PHP Fatal error: Cannot use object of type WP_Error as array in
    wordpress/wp-content/plugins/brightcove-video-connect/includes/classes/api/class-bc-cms-api.php
    on line 369
    Do you have any idea why we get this message or any answer to fix it.
    Many thanks in advance.

    https://wordpress.org/plugins/brightcove-video-connect/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Thorsten Ott

    (@tott)


    Hi there,

    we’re currently looking into this. It seems a remote request is failing on your installation. Did you manage to setup your Brightcove accounts correctly? Can you let us know which version of WordPress and the plugin you’re using?

    Thanks

    Hi Thorsten,

    first thanks to considering our problem.
    We use wordpress 4.2.3 and the latest version of your plugin.
    By the way i forgot to mention another issue with the plugin. Just after we installed the plugin due to the php error we can’t access to the details of the articles in our wordpress bac-office. we get a blank page when we tried to created or modified an article.
    To answer to your question about Brightoce account. No, we were not able to manage our Brightcove account in the setup section.

    I hope all this help you, feel free to ask more question.

    Plugin Contributor Chris Wiegman

    (@chriswiegman)


    Hi jflenilias,

    Thank you for the report. I’ve pushed version 1.0.4 to address the fatal error issue. Please let me know if you continue to see any further problems.

    Many thanks Chris, I will try this at the end of the day (Paris time) and i will keep you inform.

    Hello jflenilias,
    Did the new version resolve this for you?

    Hi There,

    really sorry for my late answer, i was in holiday with a poor internet connection so i just give a try to the news 1.04 version yesterday.
    I have a good news it works perfectly ! So many thanks to Chris and Thorsten or this update.
    By the way a small tips to make it work. On the BrightCove studio site in the API authentification process I had to tick all the options on the CMS et Players Menu.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Php error when the plugin is installed’ is closed to new replies.