Support » Plugin: Sticky Side Buttons » PHP error when activating plugin

  • Hi there,

    I am trying to install your plugin on a them (Generate Press) using wordpress 5.3.
    When I do I get the following error:
    The plugin generated 225 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.
    ( must be an array or an object that implements Countable in /home/burdeki2/staging.burdekin.org.au/wp-content/plugins/sticky-side-buttons/ssb-main.php on line 217)
    Is there something you can do to fix this?
    Many thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Yes, #metoo

    “Das Plugin erzeugte 227 Zeichen mit unerwarteter Ausgabe während der Aktivierung. Wenn Sie „headers already sent“-Hinweise, Probleme mit Syndication-Feeds oder andere Probleme bemerken, versuchen Sie, dieses Plugin zu deaktivieren oder zu entfernen.”
    => unexpected output with 227 characters

    My setup
    OceanWP 1.7.3, Elementor 2.7.3, WP 5.3, Woocommerce

    Yes, #meetoo

    My Setup is WP 5.3, with enfold and Woocommerce.

    Thanks and kind regards
    Jan

    Warning: count(): Parameter must be an array or an object that implements Countable in /home/www/wp/wp-content/plugins/sticky-side-buttons/ssb-main.php on line 217
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/www/wp/wp-content/plugins/sticky-side-buttons/ssb-main.php:217) in /home/www/wp/wp-includes/functions.php on line 5946
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/www/wp/wp-content/plugins/sticky-side-buttons/ssb-main.php:217) in /home/www/wp/wp-admin/includes/misc.php on line 1252
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/www/wp/wp-content/plugins/sticky-side-buttons/ssb-main.php:217) in /home/www/wp/wp-admin/admin-header.php on line 9

    Hi,

    after following https://wordpress.org/support/topic/error-with-php-7-2-5/ the error at line 217 is gone.

    The unexpected output after activating is still there.

    But the Plugin works fine 🙂

    Kind regards
    Jan

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.