Support » Plugin: Point of Sale POS for WooCommerce » PHP Error Log Warning

  • Resolved thebarkacademy

    (@thebarkacademy)


    Can anyone help with the following warning in my php log?

    Warning: Declaration of ZPOS\API\Taxes::get_items() should be compatible with WC_REST_Taxes_V1_Controller::get_items($request) in /srv/htdocs/wp-content/plugins/point-of-sale-pos-woocommerce/includes/API/Taxes.php on line 10

    Timestamp: 2020-01-05 13:08:03 UTC

    Stack Trace
    ———–
    1. require_once(‘/srv/htdocs/wp-content…’)
    /srv/htdocs/wp-content/plugins/point-of-sale-pos-woocommerce/index.php:40
    2. ZPOS\{closure}(Array(3))
    3. spl_autoload_call(‘ZPOS\API\Taxes’)
    /srv/htdocs/wp-content/plugins/point-of-sale-pos-woocommerce/includes/API.php:38
    4. ZPOS\API->register_rest_routes(WP_REST_Server)
    /wordpress/core/5.3.2/wp-includes/class-wp-hook.php:288
    5. WP_Hook->apply_filters(”, Array(1))
    /wordpress/core/5.3.2/wp-includes/class-wp-hook.php:312
    6. WP_Hook->do_action(Array(1))
    /wordpress/core/5.3.2/wp-includes/plugin.php:478
    7. do_action(‘rest_api_init’, WP_REST_Server)
    /wordpress/core/5.3.2/wp-includes/rest-api.php:471
    8. rest_get_server()
    /wordpress/core/5.3.2/wp-includes/rest-api.php:298
    9. rest_api_loaded(WP)
    /wordpress/core/5.3.2/wp-includes/class-wp-hook.php:288
    10. WP_Hook->apply_filters(null, Array(1))
    /wordpress/core/5.3.2/wp-includes/class-wp-hook.php:312
    11. WP_Hook->do_action(Array(1))
    /wordpress/core/5.3.2/wp-includes/plugin.php:544
    12. do_action_ref_array(‘parse_request’, Array(1))
    /wordpress/core/5.3.2/wp-includes/class-wp.php:387
    13. WP->parse_request(”)
    /wordpress/core/5.3.2/wp-includes/class-wp.php:729
    14. WP->main(”)
    /wordpress/core/5.3.2/wp-includes/functions.php:1255
    15. wp()
    /wordpress/core/5.3.2/wp-blog-header.php:16
    16. require(‘/wordpress/core/5.3.2/…’)
    /wordpress/core/5.3.2/index.php:17

    Context
    ——-
    URL : /wp-json/jetpack/v4/jitm?message_path=wp%3Aplugins%3Aadmin_notices&query=&_wpnonce=48221794a7
    Referer : https://thebarkacademy.com/wp-admin/plugins.php
    HTTP Method : GET
    HTTP Host : thebarkacademy.com
    HTTP Status : 200
    isSSL : Yes
    Current Filter : parse_request, rest_api_init
    Execution Time : 0.560 s
    Memory Usage : 55.52 MiB
    PHP SAPI : fpm-fcgi

Viewing 1 replies (of 1 total)
  • Plugin Author bizswoop

    (@bizswoop)

    Thanks for flagging this warning log. No action is needed on your side. The log is generated as part of a debug testing effort for select customers and tax classes. In the next release 1.3.3, this warning log will probably not generate.

    Quick note, if you are running your website with WP DEBUG mode enabled, you may see different logs from time to time as we continually develop the plugin fixing bugs and performance improvements.

    If you encounter any issues or bugs while using the POS plugin functionality for your business, please feel free to open up a forum issue with details.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.