Support » Plugin: All-in-One Event Calendar » PHP error log file filling up fast

  • I’m using all-in-one calendar free version and it is causing my PHP error log file to grow to 1MB overnight. Here’s the error:

    All-in-One Event Calendar: ini_set() has been disabled for security reasons @ /home/blahblahblah/public_html/wp-content/plugins/all-in-one-event-calendar/all-in-one-event-calendar.php:81 #2

    After several lines of that error, it shows a PHP deprecated notice, as follows:

    PHP Deprecated: Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead.

    My PHP version is 5.6.24.

    https://wordpress.org/plugins/all-in-one-event-calendar/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Benjamin

    (@bsokic)

    Hi Wendell,

    Your host has ini_set disabled in their php configuration so it’s throwing that error. You can safely ignore this warning, which should not show if WP_DEBUG is set to false in the wp_config.php file.

    I do already have define('WP_DEBUG', false); set in my wp-config.php file and still the error log file fills up quickly.

    Plugin Author Benjamin

    (@bsokic)

    Have you tried PHP Deprecated notice solution, to set ‘always_populate_raw_post_data’ to ‘-1’ in php.ini?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP error log file filling up fast’ is closed to new replies.