Wordfence Security
Php error in WP admin login page (7 posts)

  1. coolforyou
    Posted 1 year ago #

    Hello, when I activate wordfence on my site I get the following error in the top header of the wp-admin log in screen:

    Warning: Parameter 2 to wordfence::authActionNew() expected to be a reference, value given in (..)/public_html/wp-includes/plugin.php on line 429

    Any help would be greatly appreciated, thanks.

    (os linux)
    (apache server 2.4.6)
    (php 5.4.20)


  2. Wordfence
    Plugin Author

    Posted 1 year ago #

    Strange, we fixed this bug and we have two versions of that function for PHP before 5.4 and PHP after 5.4 to specifically deal with this issue.

    When you click the system info link at the bottom of the Wordfence options page and it opens a new window, what does the heading say?



  3. amit_siddhu
    Posted 1 year ago #

    Hi coolforyou, I think you have upgraded your server's php version. If yes than you can solve this by downgrading your php version or completely removing (including database tables) wordfence and than reinstall the fresh copy of wordfence plugin.

  4. Timotheus44
    Posted 1 year ago #

    I have same problem as coolforyou, but am creating separate ticket.

  5. coolforyou
    Posted 1 year ago #

    Hi Mark, thank you for your reply

    the header says "Wordfence system info for PHP Version 5.4.20"

    System Linux (...com) 2.6.32-458.23.2.lve1.2.45.el6.x86_64 #1 SMP Fri Nov 22 08:02:49 EST 2013 x86_64

    Build Date Sep 26 2013 13:43:38

    Configure Command './configure' '--disable-fileinfo' '--enable-bcmath' '--enable-calendar' '--enable-exif' '--enable-ftp' '--enable-gd-native-ttf' '--enable-intl' '--enable-libxml' '--enable-mbstring' '--enable-pdo=shared' '--enable-soap' '--enable-sockets' '--enable-wddx' '--enable-zip' '--prefix=/usr/local' '--with-bz2' '--with-config-file-path=/usr/local/lib' '--with-config-file-scan-dir=/usr/local/lib/php.ini.d' '--with-curl=/opt/curlssl/' '--with-curlwrappers' '--with-enchant=/usr' '--with-freetype-dir=/usr' '--with-gd' '--with-gettext' '--with-icu-dir=/usr' '--with-imap=/opt/php_with_imap_client/' '--with-imap-ssl=/usr' '--with-jpeg-dir=/usr' '--with-kerberos' '--with-libdir=lib64' '--with-libexpat-dir=/usr' '--with-libxml-dir=/opt/xml2' '--with-libxml-dir=/opt/xml2/' '--with-mcrypt=/opt/libmcrypt/' '--with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-mysqli=/usr/bin/mysql_config' '--with-openssl=/usr' '--with-openssl-dir=/usr' '--with-pcre-regex=/opt/pcre' '--with-pdo-mysql=shared' '--with-pdo-sqlite=shared' '--with-pic' '--with-png-dir=/usr' '--with-pspell' '--with-tidy=/opt/tidy/' '--with-xmlrpc' '--with-xpm-dir=/usr' '--with-xsl=/opt/xslt/' '--with-zlib' '--with-zlib-dir=/usr'

    the page is very long, do you need a specific section ?

    I reinstalled everything from scratch several times, including to the latest versions avaiable today but I still get the same error.

    Hi Amit, regarding the php version I am on shared hosting and cannot downgrade the php version :/ the reinstall did not work too

  6. Wordfence
    Plugin Author

    Posted 1 year ago #


    We've put out a few new versions since this was posted. Can you confirm that you've upgraded to the newest and that you're still seeing the error? If so post the error because the line number would have changed.



  7. kuunala
    Posted 1 year ago #

    I am still getting the same problem, when I install your plugin. The following is the link of the images of the errors I am getting, Please check
    The following is on the login page

    The following is after I enter the username and password and login from the above page:


    Please help,
    Thank you,

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Wordfence Security
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.