Title: PHP error from WPSOLR_Option.php
Last modified: August 31, 2016

---

# PHP error from WPSOLR_Option.php

 *  Resolved [akhilgopinath](https://wordpress.org/support/users/akhilgopinath/)
 * (@akhilgopinath)
 * [10 years, 5 months ago](https://wordpress.org/support/topic/php-error-from-wpsolr_optionphp/)
 * [Sun May 01 06:52:12.264964 2016] [:error] [pid 1931] [client 88.111.82.250:36976]
   PHP Warning: Illegal offset type in isset or empty in /nas/content/live/violetofficedv/
   wp-content/plugins/wpsolr-search-engine/classes/utilities/WPSOLR_Option.php on
   line 86,
 * i am getting this error after updating plugin to new version
 * [https://wordpress.org/plugins/wpsolr-search-engine/](https://wordpress.org/plugins/wpsolr-search-engine/)

Viewing 4 replies - 1 through 4 (of 4 total)

 *  Plugin Author [WPSOLR](https://wordpress.org/support/users/wpsolr/)
 * (@wpsolr)
 * [10 years, 5 months ago](https://wordpress.org/support/topic/php-error-from-wpsolr_optionphp/#post-7339192)
 * With all WP debug flags on, I cannot reproduce your problem.
 *  [fcrick](https://wordpress.org/support/users/fcrick/)
 * (@fcrick)
 * [10 years, 5 months ago](https://wordpress.org/support/topic/php-error-from-wpsolr_optionphp/#post-7339362)
 * I am getting exactly the same error :
 * Warning: Illegal offset type in isset or empty in /usr/share/nginx/html/domain.
   tld/original/wp-content/plugins/wpsolr-search-engine/classes/utilities/WPSOLR_Option.
   php on line 86
 * My environment:
    WP 4.5.1 WP-Solr 9.0 14.04.1-Ubuntu PHP Version 5.5.9-1ubuntu4.16
   FPM/FastCGI Solr: 5.5.0
 * php.ini:
    error_reporting = E_ALL display_errors = On
 * wp-config.php:
    define(‘WP_DEBUG’, true);
 * Please advise.
 * Thanks
 *  Plugin Author [WPSOLR](https://wordpress.org/support/users/wpsolr/)
 * (@wpsolr)
 * [10 years, 5 months ago](https://wordpress.org/support/topic/php-error-from-wpsolr_optionphp/#post-7339363)
 * I cannot.
 * Try to debug and get more details.
 *  Plugin Author [WPSOLR](https://wordpress.org/support/users/wpsolr/)
 * (@wpsolr)
 * [10 years, 3 months ago](https://wordpress.org/support/topic/php-error-from-wpsolr_optionphp/#post-7339406)
 * Fixed in WPSOLR 9.9
 * (I could finally reproduce the problem at a user instance)

Viewing 4 replies - 1 through 4 (of 4 total)

 The topic ‘PHP error from WPSOLR_Option.php’ is closed to new replies.

 * ![](https://s.w.org/plugins/geopattern-icon/wpsolr-search-engine_b2dbdc.svg)
 * [WPSOLR - Elasticsearch and Solr search](https://wordpress.org/plugins/wpsolr-search-engine/)
 * [Frequently Asked Questions](https://wordpress.org/plugins/wpsolr-search-engine/#faq)
 * [Support Threads](https://wordpress.org/support/plugin/wpsolr-search-engine/)
 * [Active Topics](https://wordpress.org/support/plugin/wpsolr-search-engine/active/)
 * [Unresolved Topics](https://wordpress.org/support/plugin/wpsolr-search-engine/unresolved/)
 * [Reviews](https://wordpress.org/support/plugin/wpsolr-search-engine/reviews/)

 * 4 replies
 * 3 participants
 * Last reply from: [WPSOLR](https://wordpress.org/support/users/wpsolr/)
 * Last activity: [10 years, 3 months ago](https://wordpress.org/support/topic/php-error-from-wpsolr_optionphp/#post-7339406)
 * Status: resolved