Support » Plugin: Cache Sniper for Nginx » PHP Error after Update

  • Resolved Myar

    (@myar)


    Hello,

    first thank you very much for this update, it implements features that I realy needed.

    But after this update, when I answer a comment over the dashboard, I am getting an error. The Answer is in the database and after reloading the page I can see it, but this appears in the error log:

    2018/09/19 11:30:34 [error] 782#782: *198121 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught ArgumentCountError: Too few arguments to function Cache_Sniper_Nginx_Comments::csnx_delete_current_page_cache_on_wp_insert_comment(), 1 passed in /wp-includes/class-wp-hook.php on line 288 and exactly 2 expected in /wp-content/plugins/snipe-nginx-cache/includes/cache-sniper-nginx-comments.php:50
    Stack trace:
    #0 /wp-includes/class-wp-hook.php(288): Cache_Sniper_Nginx_Comments->csnx_delete_current_page_cache_on_wp_insert_comment(2009)
    #1 /wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters('', Array)
    #2 /wp-includes/plugin.php(453): WP_Hook->do_action(Array)
    #3 /wp-includes/comment.php(1811): do_action('wp_insert_comme...', 2009, Object(WP_Comment))
    #4 /wp-includes/comment.php(1996): wp_insert_comment(Array)

    Can you check this?

    Regards
    Myar

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author ekaterir

    (@ekaterir)

    Hello @myar,

    Thank you for the feedback. I just pushed a fix. Let me know if it worked and I’ll resolve this support issue.

    Thanks again,
    ekaterir

    Thread Starter Myar

    (@myar)

    Hello ekaterir,

    it worked, nor error messages! 🙂

    Thank You!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘PHP Error after Update’ is closed to new replies.