Support » Plugin: Black Studio TinyMCE Widget » PHP error

  • zsujoker

    (@zsujoker)


    Hello,

    Could you help me?
    I receive this error on my site:

    PHP Deprecated: Non-static method Black_Studio_TinyMCE_Compatibility_Plugins::siteorigin_panels_enable_pages() should not be called statically in /public_html/wp-includes/class-wp-hook.php on line 287

    Thank you.

    Zsuzsa

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Marco Chiesi

    (@marcochiesi)

    Hello @zsujoker
    Thank you for your report.
    Please could you specify the following information related to your instance?

    • PHP version
    • WordPress version
    • Black Studio TinyMCE Widget plugin version
    Thread Starter zsujoker

    (@zsujoker)

    Hello,

    Wordpress: 5.6.2
    PHP: 7.3.23
    Black Studio: 2.6.9

    Hope this helps!

    Thread Starter zsujoker

    (@zsujoker)

    I am also receiving another error, I am notsure it is related:
    PHP Deprecated: media_buttons_context is deprecated since version 3.5.0! Use media_buttons instead.
    /public_html/wp-includes/functions.php on line 5234

    Plugin Author Marco Chiesi

    (@marcochiesi)

    Hello @zsujoker
    Unfortunately, I am not able to reproduce the error you reported using the same conditions.

    The error message is claiming that the method Black_Studio_TinyMCE_Compatibility_Plugins::siteorigin_panels_enable_pages() should not be called statically, but actually, it’s not called statically from inside the plugin.

    I suspect there could be some other piece of code that is calling that method statically.

    Please could you specify which theme are you using and which other plugins are present? Also, if there’s any 3rd party additional custom code on the website.
    Specifically there seems to be something that is calling Black_Studio_TinyMCE_Compatibility_Plugins::siteorigin_panels_enable_pages().
    If you could look in your entire codebase for “Black_Studio_TinyMCE_Compatibility_Plugins” or “siteorigin_panels_enable_pages”, it could help to find the culprit.

    With regard to the latest error, I don’t think it’s related to our plugin. In our plugin, the media_buttons_context action is not used at all in favor of media_buttons.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘PHP error’ is closed to new replies.