Support » Plugin: SR Product 360° View » PHP error

  • Resolved Hembike

    (@hembike)


    Error message:
    Unparenthesized a ? b : c ? d : e is deprecated. Use either (a ? b : c) ? d : e or a ? b : (c ? d : e)

    wp-content/plugins/sr-product-360o-view/class.php:269
    wp-content/plugins/sr-product-360o-view/class.php:270

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Super Rishi

    (@superrishi)

    Hello, @hembike which PHP version you are using? I am not able to duplicate the same error and tried with PHP versions 5.4 – 7.2
    It would be helpful for me to get this error if you can give me more details about the environment you are running your website on. Thank you.

    Thread Starter Hembike

    (@hembike)

    Hello,
    I tried with PHP 7.4.

    Plugin Author Super Rishi

    (@superrishi)

    Thank you for sharing your php version. I have tried with 7.4 and plugin is working fine on my side. If you can, send me your website details at info@superrishi.com so I can look into it from dashboard. Thank you.

    Plugin Author Super Rishi

    (@superrishi)

    Hello @hembike I am able to duplicate this issue on my side. Let me know if you are still getting this error on your website? So, I will help you fix it.

    Thread Starter Hembike

    (@hembike)

    Hello,

    Sorry for the late reply. I still have this error, on PHP 7.4.
    “PHP Deprecated: Unparenthesized a ? b : c ? d : e is deprecated. Use either (a ? b : c) ? d : e or a ? b : (c ? d : e) in /wp-content/plugins/sr-product-360o-view/class.php on line 270″

    and I got a new one:
    “Cannot modify header information – headers already sent by (output started at /wp-content/plugins/sr-product-360o-view/class.php:269)”

    How could you fix it?

    • This reply was modified 9 months, 2 weeks ago by Hembike.
    Plugin Author Super Rishi

    (@superrishi)

    Hi,

    It’s no problem. Thank you for sharing another issue. If you can share your email address, I will send you the updated class.php file, which will resolve the issue on your website, or if you like, by this weekend, I will upload a new version of this plugin with a solution for these errors. Thank you.

    Thread Starter Hembike

    (@hembike)

    I prefer the plugin version update, thank you for your work!

    Plugin Author Super Rishi

    (@superrishi)

    Hello @hembike
    Sorry for the delay in the new update of the plugin, as there are some more urgent fixes undergoing. I want to notify you, that the new version of the plugin will be uploaded by the 25th of Jan. I appreciate your patience and support. Thank you.

    Plugin Author Super Rishi

    (@superrishi)

    Hello @hembike , new update of plugin is available now. Can you check and let me know if the issue you were facing is resolved with this update? Thank you.

    Plugin Author Super Rishi

    (@superrishi)

    Hello @hembike I haven’t received your reply to the last update, yet. I am closing this issue, as I fixed it in the recent version of the plugin. If you find it unresolved you can always reopen this issue. Thank you.

    Plugin Author Super Rishi

    (@superrishi)

    Issue is now resolved.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘PHP error’ is closed to new replies.