Support » Plugin: WP Cloudy » php encoding errors continues

  • Resolved kryvulena



    I just updated the plugin to v2.7.5 and I get this error quite often:

    Fatal error: Call to a member function asXML() on a non-object in /wp-content/plugins/wp-cloudy/wpcloudy.php on line 2039

    Fatal error: Call to a member function asXML() on a non-object in /wp-content/plugins/wp-cloudy/wpcloudy.php on line 2016


    Fatal error: Call to a member function asXML() on a non-object in /wp-content/plugins/wp-cloudy/wpcloudy.php on line 1994

    Any page displaying the plugin still loads slower than any page w/o it and it loads noticeably slower than it used to be before…

    There is a problem with non-English characters encoding, they are all replaced with ´┐Ż sign. Additionally there are still some words remaining in English, although I choose another language from the lang. list.

Viewing 15 replies - 1 through 15 (of 26 total)
  • Plugin Author rainbowgeek



    Please upgrade to the latest version of WPCloudy (2.7.7) to fix this issue.

    Let me know if there is any trouble!

    For translation please read this =>

    If you have trouble with characters encoding, it’s related to your webhost that does not support your language.

    My webhost supports my language on 100% – I called them and read their spec. Moreover I’ve never experienced any issues like that with any other plugins (managing 40+ WP sites here…). The issue is not retalet to the .po file – the errors come within words that are taken automatically by the plugin from somewhere else. There are no day names in the .po file to be translated.

    Btw thanks for the update, I will test it today and will try to provide a feedback if any issues encountered again. Happy to contribute to make the plugin better!

    Plugin Author rainbowgeek


    Thank you for your support!

    FYI, I use 2 PHP functions to display days:
    – setlocale =

    and strftime =

    Unfortunately, it is difficult to test this stuff without having servers spread across several countries.

    Nevertheless, I will continue to investigate that ­čÖé

    Plugin Author rainbowgeek


    Can you give the desired language please?

    Most of my WP sites I manage are Polish based. I tested php locale at my server and it’s fully supported for Polish. Maybe the case is encoding-related. But it’s a virtual host so I cannot access any php settings there.

    Plugin Author rainbowgeek


    Can you try editing this line in wpcloudy.php (2001):

    $wpcloudy_lang_host = ‘polish’;

    by putting this:

    $wpcloudy_lang_host = ‘pl_PL’;

    Let me know if it’s better!

    I found that at line #1957 – not #2001

    changed to $wpcloudy_lang_host = ‘pl_PL’;

    No change, unfortunately

    Plugin Author rainbowgeek


    Can you give me a link to your site?

    May I have your email address to send the url to please, I’d like to keep the site private until it’s done.

    Plugin Author rainbowgeek


    There it is:

    Plugin Author rainbowgeek


    Can you replace line 2154 (//Forecast loop) by this please:

    $forecast_day_[$i] = utf8_encode(strftime(“%A”, strtotime($myweather_sevendays->forecast[0]->time[$i][‘day’])));

    It didn’t help. I get “Poniedzia┬│Ek” instead “Poniedzia┼éek”

    Plugin Author rainbowgeek


    I do not have the exact line because I use a dev version.
    But, when you see this code, replaced it with this one:

    			//Forecast loop
    			while ($i<=13) {
    				$forecast_day_[$i]			= utf8_encode(strftime("%A", strtotime($myweather_sevendays->forecast[0]->time[$i]['day'])));
    				$forecast_number_[$i]		= $myweather_sevendays->forecast[0]->time[$i]->symbol[0]['number'];
    				$forecast_temp_min_[$i]		= (round($myweather_sevendays->forecast[0]->time[$i]->temperature[0]['min']));
    				$forecast_temp_max_[$i]		= (round($myweather_sevendays->forecast[0]->time[$i]->temperature[0]['max']));
    Plugin Author rainbowgeek


    OK! I continue to investigate!

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘php encoding errors continues’ is closed to new replies.