Support » Plugin: Post SMTP Mailer/Email Log » PHP Deprecated error

  • Resolved nattila

    (@nattila)


    hi,

    plugin thows this error continously:

    [20-Dec-2020 08:50:31 UTC] PHP Deprecated: implode(): Passing glue string after array is deprecated. Swap the parameters in /home/aecohu/public_html/wp-content/plugins/post-smtp/Postman/Postman-Mail/google-api-client/vendor/google/apiclient/src/Google/Service/Resource.php on line 291

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Tim

    (@tneville)

    Hi @nattila,

    What PHP version are you using?
    Have you tried a fresh install of the plugin from the WP repo?

    Kind Regards,
    Tim

    Thread Starter nattila

    (@nattila)

    Hi,

    Based on cpanel, I am using PHP 7.4 (ea-php74).
    As I can see I am using 2.0.16 version of the plugin. This looks to me up to date.

    Attila

    Plugin Support Tim

    (@tneville)

    Hi Attila,

    I believe there are a few stability issues with PHP 7.4, I would recommend dropping back down to 7.3. This is not unique to PostSMTP – I have come across various plugins that have a few stability issues on 7.4.

    PostSMTP 2.0.16 is indeed the latest version at time of writing.

    Hope this helps.

    Kind Regards,
    Tim

    Plugin Support Tim

    (@tneville)

    Hi @nattila,

    I have another thread about this which I have shared with the developer for consideration on a future release.

    Kind Regards,
    Tim

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.