• Resolved anncskay

    (@anncskay)


    I had a fatal error message from WordPress to do with a compatibility issue with Content Aware Sidebars (version 3.16.1) and PHP version 7.4.20, I’ve had to roll back my site PHP to version 7.3 and restored my site so that it’s visible, but please can you look into the issue.

    I am running WordPress version 5.7.2
    Current theme: Astra (version 2.6.2)

    The error message was this:

    Error Details
    =============
    An error of type E_COMPILE_ERROR was caused in line 10 of the file /home/customer/www/centreformindfulliving.org/public_html/wp-content/plugins/content-aware-sidebars/lib/freemius/require.php. Error message: require_once(): Failed opening required ‘/home/customer/www/centreformindfulliving.org/public_htmk/wp-content/plugins/content-aware-sidebars/lib/freemius/config.php’ (include_path=’.:/usr/local/php74/pear’)

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author Joachim Jensen

    (@intoxstudio)

    Thank you for reporting this.

    Unfortunately I am unable to reproduce the problem. In my test environment I have PHP7.4, and the majority of CAS users are using 7.4+ as well; the plugin currently has full support for all versions between 5.6 – 8.x.

    The error looks like a missing file and not anything specific to PHP7.4 per se.

    If you decide to try upgrading to PHP7.4 again, and you get the same error, I would recommend reinstalling the plugin to rule out a corrupt install.

    I hope this helps!

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.