Support » Plugin: Rating-Widget: Star Review System » PHP Compatibility Checker Rating-Widget

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Vova Feldman

    (@svovaf)

    Could you please share a screenshot/list of the found issues?

    FILE: /srv/www/staging.avelim.co.il/public_html/wp-content/plugins/rating-widget/view/options.php
    ————————————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————————————-
    1 | WARNING | File has mixed line endings; this may cause incorrect results
    ————————————————————————————————-

    FILE: /srv/www/staging.avelim.co.il/public_html/wp-content/plugins/rating-widget/freemius/includes/fs-essential-functions.php
    —————————————————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————————————————————
    147 | WARNING | Function name “__fs” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    —————————————————————————————————————————————

    FILE: /srv/www/staging.avelim.co.il/public_html/wp-content/plugins/rating-widget/lib/rw-core-rw-functions.php
    ————————————————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————————————————————————–
    32 | WARNING | Function name “__rw” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    ————————————————————————————————————————————–

    FILE: /srv/www/staging.avelim.co.il/public_html/wp-content/plugins/rating-widget/lib/rw-top-rated-widget.php
    ————————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————————————————
    1 | WARNING | File has mixed line endings; this may cause incorrect results
    ————————————————————————————————————

    FILE: /srv/www/staging.avelim.co.il/public_html/wp-content/plugins/rating-widget/rating-widget.php
    —————————————————————————————————————–
    FOUND 4 ERRORS AND 1 WARNING AFFECTING 5 LINES
    —————————————————————————————————————–
    1 | WARNING | File has mixed line endings; this may cause incorrect results
    4547 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.
    4555 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.
    4558 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.
    4559 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.
    —————————————————————————————————————–

    Plugin Author Vova Feldman

    (@svovaf)

    Thanks for the output Yoram, we’ll make the required changes to be compliant for PHP 7 for the next release.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP Compatibility Checker Rating-Widget’ is closed to new replies.