Support » Plugin: Better Search Replace » PHP Compatibility Checker; OK to ignore warning before PHP7 update?

  • Hi Better Search Replace plugin author(s):

    I’m wanting to know if there are any significant reasons or concerns why I should not upgrade my site to PHP7, after reading this article:

    https://wpengine.com/support/php-7-faq/

    … and running this PHP 7 test plugin:

    https://wordpress.org/plugins/php-compatibility-checker/

    … and seeing these warnings:

    FILE: /nas/content/staging/fipweb/wp-content/plugins/better-search-replace/includes/class-bsr-compatibility.php
    —————————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————————————
    54 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    ———————————————————————————————————————————————————————

    … associated with the plugin:

    https://wordpress.org/support/plugin/better-search-replace

    Please advise if these warnings can be safely ignored before updating to PHP7.

    THANKS! 🙂

  • You must be logged in to reply to this topic.