Support » Plugin: TablePress » PHP Compatibility Checker Errors with TablePress 1.11

  • Resolved runbei

    (@runbei)


    Hello, we’re using TablePress 1.11. We had trouble with another plugin so I ran the PHP Compatibility Checker and it didn’t find errors for TablePress, but it did give the following warnings – thought you might want to know in case an update is advisable. Great plugin!

    Name: TablePress

    FILE: /home/fitne962/public_html/livingwisdomschool.org/wp-content/plugins/tablepress/libraries/simplexlsx.class.php
    ——————————————————————————————————————–
    FOUND 0 ERRORS AND 5 WARNINGS AFFECTING 5 LINES
    ——————————————————————————————————————–
    960 | WARNING | INI directive ‘mbstring.func_overload’ is deprecated since PHP 7.2
    963 | WARNING | INI directive ‘mbstring.func_overload’ is deprecated since PHP 7.2
    966 | WARNING | INI directive ‘mbstring.func_overload’ is deprecated since PHP 7.2
    969 | WARNING | INI directive ‘mbstring.func_overload’ is deprecated since PHP 7.2
    972 | WARNING | INI directive ‘mbstring.func_overload’ is deprecated since PHP 7.2
    ——————————————————————————————————————–

    Name: TablePress Extension: Responsive Tables

    PHP 7.3 compatible.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your post, and sorry for the trouble.

    No worries, these are false positives here. TablePress will only use these functions if they are available. On PHP 7.3 it will not use them so that nothing bad will happen.
    You can therefore ignore this. TablePress is fully compatible to PHP 7.3 and PHP 7.4.

    Regards,
    Tobias

    Thread Starter runbei

    (@runbei)

    Cool. Thank you – good to know!

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    sure, no problem!

    Best wishes,
    Tobias

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP Compatibility Checker Errors with TablePress 1.11’ is closed to new replies.