Support » Plugin: WP Broken Link Status Checker » PHP compatibility

  • Resolved Rita

    (@ritahoock)


    PLease check:
    561 | ERROR | preg_replace() – /e modifier is deprecated since PHP 5.5

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Pau Iglesias

    (@pauiglesias)

    Hi Rita, sorry but I do not think the plugin is generating that error.

    Please tell me which file shows in your error log to do a quick check.

    Kind regards,
    Pau

    Rita

    (@ritahoock)

    Detected by using https://wordpress.org/plugins/php-compatibility-checker/

    The file is:

    plugins/wp-link-status/core/requests/class-json.php
    ——————————————————————————————————-
    FOUND 1 ERROR AFFECTING 1 LINE
    ——————————————————————————————————-
    561 | ERROR | preg_replace() – /e modifier is deprecated since PHP 5.5
    ——————————————————————————————————-

    Plugin Author SeedPlugins

    (@seedplugins)

    Ok, thanks for the details, then the PHP Compatibility Checker plugin is wrong, that line does not have the /e modifier in preg_replace function, in fact that file is a copy of class-json.php file from the WP core, so if this plugin is not compatible then the entire WP is neither compatible.

    Kinds regards,
    Pau

    Rita

    (@ritahoock)

    Sorry.
    I just opened thread at PHP COmpatibility Checker.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘PHP compatibility’ is closed to new replies.