Support » Plugin: WPPizza - A Restaurant Plugin » PHP compatibility

  • Resolved aibrean

    (@aibrean)


    I’m on PHP 7.1 and I’m getting this issue:

    Warning: A non-numeric value encountered in ….wppizza/classes/admin/class.wppizza.user_caps.inc.php on line 417

    It’s just a warning so I can suppress it with debug mode off. Has this been tested with the latest version of PHP?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author ollybach

    (@ollybach)

    – this has been tested with (pretty much) all version from 5.3 up to the current 7.3

    – i have installed the plugin hundreds (probably 1000’s) of times without ever getting that warning, so i can only assume some other plugin or custom coding/filter is altering the default behaviour of the native (though pluggable) WP wp_get_current_user function

    • This reply was modified 10 months, 3 weeks ago by ollybach.

    That’s entirely possible. I didn’t build the site, but working on getting it updated and I have no idea what has been done to it.

    Plugin Author ollybach

    (@ollybach)

    thing is, i could add a conditional that would result in this warning not showing anywhere, but the problem is that a plugin/coding that changes this default WP functions behaviour *might* subsequently result in the access/permissions structure inbuilt into the plugin regarding who can access what wppizza (admin) pages getting messed up so am not entirely sure whether or not this would actually be a good thing to do.
    It could potentially just add other issues further down the line

    i’ll mull it over for a bit i guess..

    • This reply was modified 10 months, 3 weeks ago by ollybach.
    Plugin Author ollybach

    (@ollybach)

    out of interest, do you have any kind of permission/access plugins installed there ?
    (and if so , which one. perhaps i can see if i can reproduce this here and ascertain if there’s a safe workaround for this)

    I have it in a testing environment and could give you access. The warnings only display in the backend. I’ll contact you through your site contact page.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘PHP compatibility’ is closed to new replies.