Support » Plugin: PG Simple Affiliate Shop » PHP Compatability

  • healthysolutions4living

    (@healthysolutions4living)


    Getting PHP compatibility errors.
    Wanted to post a screenshot but can’t.
    Send me an email and I will forward.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author PeoplesGeek

    (@peoplesgeek)

    Hi John,

    Nice to see you again and I hope you are keeping well.

    I have visited the page you suggested and can’t see any error or warning messages (which is good for your visitors). If they are appearing elsewhere then we will get to the bottom of this.

    As per our email conversation: if you could let me know the exact PHP error you are seeing, and where it appears, that would help. I am due to release an updated version of the plugin and PHP compatibility with the latest versions is on the list.

    I am reading between the lines that you are using a compatibility checker and guess it is https://wordpress.org/plugins/php-compatibility-checker/ so I will install that and have a look to see if I can reproduce the issue.

    [ Signature deleted ]

    • This reply was modified 2 months, 4 weeks ago by Jan Dembowski.
    healthysolutions4living

    (@healthysolutions4living)

    Sorry, got back late last night. Two warnings came up.

    FILE: /home2/ealticm4/public_html/healthysolutions4living/wp-content/plugins/pg-simple-affiliate-shop/inc/pg-options.php
    ————————————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————————————————————
    44 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ————————————————————————————————————————

    FILE: /home2/ealticm4/public_html/healthysolutions4living/wp-content/plugins/pg-simple-affiliate-shop/shop.php
    ————————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————————————————–
    86 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ————————————————————————————————————–

    Plugin Author PeoplesGeek

    (@peoplesgeek)

    Hi John, @healthysolutions4living

    I have been able to reproduce the waning using the compatibility plugin and it is a warning only which is good (ie not an ‘error’ in PHP terms)

    I will still make the adjustment to the plugin with the next release so that this does not cause anyone else concern.

    I will update this ticket when the new release is released (shortly).

    Cheers and thanks for raising it with me,

    Brian (PeoplesGeek)

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.