P3 (Plugin Performance Profiler)
[resolved] PHP and JS Errors in Plugin (5 posts)

  1. freakyleaf
    Posted 2 years ago #


    Have just run P3 for the first time. The tests ran successfully, but when I view the results I don't get any visuals (see http://postimg.org/image/i9i4of1a7/).

    I also get a PHP error:

    Warning: Invalid argument supplied for foreach() in /var/sites/t/xxxxx/public_html/wp-content/plugins/p3-profiler/classes/class.p3-profiler-reader.php on line 293

    And a JS error:

    Uncaught SyntaxError: Unexpected token }

    I'm using WordPress 3.7.1, P3 1.4.1 and Chrome 31.

    Any help greatly appreciated! :)

    Many thanks



  2. freakyleaf
    Posted 2 years ago #

    Sorry - link to screenshot is http://postimg.org/image/i9i4of1a7/

    WP included the braket in the URL.

  3. Kurt Payne
    Plugin Contributor

    Posted 2 years ago #

    Hi freakyleaf,

    Two questions: Can you repeat this with all plugins disabled and your theme reverted to twentythirteen?

    In the P3 help page, there's a question about "Is my site using an opcode cache" ... what does it say for your site?

  4. 42functions
    Posted 1 year ago #

    Hey Kurt & Others,

    Its an issue regarding floating numbers (i think due to locale). On my locale floats were outputted as such '0,000124'. The comma should be a dot in javascript in order to be valid.

    Converting line 172 in view-scan.php to: data: <?php echo str_replace(',','.', $v); ?> worked for me

  5. Kurt Payne
    Plugin Contributor

    Posted 1 year ago #

    Hi 42functions,

    What is your system's locale?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • P3 (Plugin Performance Profiler)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic