Support » Plugin: Themify - WooCommerce Product Filter » PHP 8 deprecations

  • The following appear in the WordPress admin when running PHP 8:

    Deprecated: Required parameter $type follows optional parameter $cats in .../plugins/themify-wc-product-filter/includes/class-wpf-form.php on line 1120
    
    Deprecated: Required parameter $value follows optional parameter $cats in .../app/plugins/themify-wc-product-filter/includes/class-wpf-form.php on line 1120
    
    Deprecated: Required parameter $lang follows optional parameter $cats in .../plugins/themify-wc-product-filter/includes/class-wpf-form.php on line 1120
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author themifyme

    (@themifyme)

    Hi @eclev91

    I will ask our developer to check what could cause the errors, but please contact us via email at info@themify.me with a link to this thread and a link to your website ( also make sure to keep PHP 8 active, so we can see the error.

    Thread Starter eclev91

    (@eclev91)

    I’m not leaving up a live site with PHP notices, ha! This is in my development environment to ensure these things are ironed out before I deploy PHP 8 to any production environments.

    The reason for the notices is pretty self-evident in the messages, and enabling PHP 8 in a dev environment should trigger them. I look forward to an update.

    Plugin Author themifyme

    (@themifyme)

    Hi,

    Please set that up on a staging site or a separate server where you can enable PHP 8 without affecting your live site, then send us a link to your website and a link to this thread via email to info@themify.me, so we can forward this issue to our developer.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.