Support » Plugin: ManageWP Worker » PHP 8.1 deprecated




    We’ve found a deprecation problem for PHP 8.1 in your worker plugin.

    In worker/src/MWP/Worker/Request.php on Line 198, you have an NULL value that you pass to the base64_decode function. That is no longer allowed and deprecated with PHP 8.1. Looks like the $this->signatureHeaderName is not found in $this->getHeader(). We’ve temporarily fixed it by either returning an empty strinng instead of NULL or replace the line base64_decode($this->getHeader($this->signatureHeaderName)) with base64_decode($this->getHeader($this->signatureHeaderName) ?? ''). We dont know what consequenses this has, but it would be appreciated if you could fix this asap. We dont want to change the code manually on all of our customers websites, thats a lot of work…

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support ddragovic


    Hello there,

    Our plugin should be fully compatible with PHP 8.0 and above. The user’s issues in the past were usually resolved by clearing the worker entries in the database as they were cached.

    The reason why this happens, in general, is that, for some reason, the Worker plugin’s entries (starting with “mwp_”) in the database’s wp-options table get written differently than expected.

    It appears that some caching functionalities, such as perhaps the “Object Cache” or any cache related to Redis or on the server, may have caused the “mwp_” entries to be populated with the wrong format in the wp-options database table.

    If you are willing to try some steps in order to be running the higher PHP version than 7.4, here’s what you can do:

    – Delete the Worker plugin from this site
    – Go to wp-content/mu-plugins folder and see if there’s a 0-worker.php under there – it it’s there, delete it
    – Go to the database and please make a manual backup (export it)
    – Search for entries that start with mwp_ in the wp_options table
    – Delete the entries
    – Clear any cache that you may have on your website and on the server
    – Reinstall the Worker plugin

    Here’s a screenshot of how you can search for the tables:


    Once you’ve removed all entries, please clear your website’s cache and re-install the Worker plugin again.

    Thread Starter FAKTOR VIER



    I’ve seen this response to another issue, but thats way too much work for us to do this for all our customers and all environments. It just can’t be that this is an issue that has to be resolved manually on every installation.

    I would really expect to receive some kind of update script in a plugin version that fixes this automatically.

    Also, do we have to reconnect all pages manually again in ManageWP?

    Thread Starter FAKTOR VIER


    @ddragovic So no followup on this? We really have to do this steps you mentioned above for over 100 environments?

    Plugin Support aleksandralazic


    Hey there,

    I understand this action demands a huge amount of your time, however, currently, we are able to provide only the workaround that David mentioned in his previous response. Unfortunately, this has to be done for each website manually, as well as the reconnection. What I can suggest additionally, is that you open the ticket related to this issue from your account, that way we will be able to forward your feedback to our developers for further investigation. You can also write us at

    Thread Starter FAKTOR VIER


    @aleksandralazic @ddragovic

    We tried all the steps prived above but we still get deprecation warnings from your plugin. And thats exactly the deprecation warning caused by the code I mentioned in the original post at the start. It would be appreciated if you could update your plugin with this simple mentioned fix.

    We need a working solution until the end of this month. If thats not possible until then, we have to look for alternatives or other solutions.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.