Support » Plugin: WP-Stateless - Google Cloud Storage » PHP 8.1 Compatibility Warning

  • Hey there, hope you guys doing well.

    This not that serious but the message keeps coming which is annoying sometimes.

    PHP Deprecated: Return type of wpCloud\StatelessMedia\Sync\BackgroundSync::jsonSerialize() should either be compatible with JsonSerializable::jsonSerialize(): mixed, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /wp-content/plugins/wp-stateless/lib/classes/sync/class-background-sync.php on line 429

    Can you guys check this?

    – Regards

  • You must be logged in to reply to this topic.