Support » Plugin: Yoast SEO » PHP 8.1 Compatibility

  • Resolved T4ng

    (@schwipps)


    Do you know if Yoast SEO is now fully compatible with php 8.1?

    Last time we tried, april 22, we faced the encountered the following error.?

    Fatal error: Uncaught TypeError: Yoast\WP\SEO\Initializers\Disable_Core_Sitemaps::__construct(): Argument #1 ($options) must be of type Yoast\WP\SEO\Helpers\Options_Helper, Yoast\WP\SEO\Helpers\Options_Helper given, called in [...]/wp-content/plugins/wordpress-seo/src/generated/container.php on line 2948 and defined in [...]/wp-content/plugins/wordpress-seo/src/initializers/disable-core-sitemaps.php:38 Stack trace: #0 [...]/wp-content/plugins/wordpress-seo/src/generated/container.php(2948): Yoast\WP\SEO\Initializers\Disable_Core_Sitemaps->__construct() #1 [...]/wp-content/plugins/wordpress-seo/vendor_prefixed/symfony/dependency-injection/Container.php(271): Yoast\WP\SEO\Generated\Cached_Container->getDisableCoreSitemapsService() #2 [...]/wp-content/plugins/wordpress-seo/src/loader.php(186): YoastSEO_Vendor\Symfony\Component\DependencyInjection\Container->get() #3 [...]/wp-content/plugins/wordpress-seo/src/loader.php(131): Yoast\WP\SEO\Loader->load_initializers() #4 [...]/wp-content/plugins/wordpress-seo/lib/abstract-main.php(43): Yoast\WP\SEO\Loader->load() #5 [...]/wp-content/plugins/wordpress-seo/src/functions.php(36): Yoast\WP\Lib\Abstract_Main->load() #6 [...]/wp-content/plugins/wordpress-seo/wp-seo-main.php(488): YoastSEO() #7 [...]/wp-content/plugins/wordpress-seo/wp-seo.php(50): require_once('...') #8 [...]/wp-settings.php(418): include_once('...') #9 [...]/wp-config.php(152): require_once('...') #10 [...]/wp-load.php(50): require_once('...') #11 [...]/wp-admin/admin.php(34): require_once('...') #12 [...]/wp-admin/plugins.php(10): require_once('...') #13 {main} thrown in [...]/wp-content/plugins/wordpress-seo/src/initializers/disable-core-sitemaps.php on line 38

    Has thi been fixed since?

    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter T4ng

    (@schwipps)

    ?

    Plugin Support Maybellyne

    (@maybellyne)

    Hello Schwipps,

    Thanks for reaching out regarding the compatibility between the Yoast SEO plugin and PHP 8.1. Unfortunately, we haven’t yet fully tested the plugin with PHP version 8. The entire WordPress community is still working on it. You can read the https://developer.yoast.com/blog/the-2020-wordpress-and-php-8-compatibility-report/.

    For Yoast SEO to run properly, you should have a PHP version of 5.6.20 or higher. In fact, we recommend PHP version 7.3 or above. Before you upgrade to a higher PHP version, check if your WordPress site is ready for it. Read this helpful article to learn how to update your PHP version. Also, your PHP memory should be 256M or greater.

    Thank you.

    Thread Starter T4ng

    (@schwipps)

    Hello @maybellyne,

    Thank you for your reply.

    The php 8 post you offered was published in October 2020.
    We already run php 7.3, but its security support ended in December, 2021.
    And php 7.4 security support will also end very soon: October 2022 (source)
    Beyond performance, it’s now more a security concern, qnd that’s why we’re looking forward to upgrade.

    Your plugin is one of the last ones preventing us to upgrade our environment. Others plugins are quite proactive to fix errors we provide them with php 8.

    I understand it can take time to make a plugin compatible with a new php versions. But it’s been almost 2 years you guys claim working on it.

    Do you have a rough ETA of when this will be completed?

    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.