Support » Plugin: The Events Calendar » PHP 8.1 compatibility

  • Resolved sosere

    (@sosere)


    Hi there

    After update php to 8.1 I got this:

    Deprecated: Return type of TEC\Events\Custom_Tables\V1\Migration\Reports\Site_Report::jsonSerialize() should either be compatible with JsonSerializable::jsonSerialize(): mixed, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /../../wp-content/plugins/the-events-calendar/src/Events/Custom_Tables/V1/Migration/Reports/Site_Report.php on line 195

    Calendar completely broken. Downgrading is not an option because of other plugins. Is there a solution on the way?

    • This topic was modified 8 months ago by sosere.
    • This topic was modified 8 months ago by sosere.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter sosere

    (@sosere)

    Version 6.1.2.2 is installed

    Plugin Support Darian

    (@d0153)

    Hi @sosere

    Thanks for reaching out, and my sincerest apologies for the inconvenience.

    We regret to inform you that our plugins are not yet fully compatible with PHP 8.1. However, we want to assure you that we are actively working on updating our plugins to be compatible with PHP 8.1. This will enable us to take advantage of the improved security and performance features that this version offers.

    Calendar completely broken. Downgrading is not an option because of other plugins. Is there a solution on the way?

    Let me share this with the team, and I’ll get back to you once i know more.

    Plugin Support Darian

    (@d0153)

    Hi @sosere

    I’m reaching out to let you know that we’ve created an internal ticket to address the issue you reported, and we’ve included your case in it.

    Unfortunately, we don’t have an estimated time for when the issue will be resolved, but we’ll keep you updated as soon as a solution becomes available.


    Internal Bug Ticket Reference: BTRIA-1906

    Plugin Support Guga Alves

    (@gugaalves)

    Hi there,

    We’re back with good news!

    We’ve just released The Events Calendar version 6.2.3, which addresses a fix for that issue!

    Please update your Events Calendar plugins, and that issue should be gone.

    Best regards,

    Plugin Support Darian

    (@d0153)

    Hi @sosere

    It appears that there hasn’t been any recent activity on this thread, so we’ll consider it resolved. However, if you have any additional questions or concerns, feel free to start a new thread.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.