Support » Plugin: WordPress Error Monitoring by Bugsnag » PHP 8.0 Compatibility

  • Hi there,
    The current version of this plugin is not compatible with PHP8.0.

    Here is the error log:

    
    30-Mar-2021 08:42:16 UTC] PHP Fatal error:  Uncaught ValueError: curl_setopt(): Argument #2 ($option) is not a valid cURL option in ../plugins/bugsnag/bugsnag-php/Notification.php:239
    #0 ../plugins/bugsnag/bugsnag-php/Notification.php(239): curl_setopt()
    #1 ../plugins/bugsnag/bugsnag-php/Notification.php(164): Bugsnag_Notification->postWithCurl()
    #2 ../plugins/bugsnag/bugsnag-php/Notification.php(124): Bugsnag_Notification->postJSON()
    #3 ../plugins/bugsnag/bugsnag-php/Client.php(638): Bugsnag_Notification->deliver()
    

    Is there an update on the way?

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.