Support » Plugin: amr shortcode any widget » PHP 7 warning

  • Alex

    (@alexh_)


    Hi,

    I found the following warning with PHP 7:

    FILE: /www/htdocs/w00e137d/portfolios/alexanderhaller/wp-content/plugins/amr-shortcode-any-widget/amr-shortcode-any-widget.php
    —————————————————————————————
    1 | WARNING | File has mixed line endings; this may cause incorrect results

    Can you pls fix this?
    Thx a lot!

Viewing 1 replies (of 1 total)
  • Plugin Author anmari

    (@anmari)

    Hi Alex,

    I’ve rechecked my local files – no mixed line endings there. and testing on php 7.0.3 on my local sites also does not give any warning (i work with debug on). I svn’ed down the latest version and it also seems fine (apart from seeing that it was svn/ing down all as LF, when it should have had a native setting!) – but either way, again, not mixed line endings!

    I’ve run the php 7 compatibility checker plugin on a couple of remote sites that use the shortcode plugin (sites still on php 5.6 though) and the plugin reports that all is well for php 7 compatibility, no mixed endings.

    In searching and trying to work out how your version may have ended up with mixed endings, the only thing I can think of, is that perhaps you opened a file and created a blank line somewhere? THere is an old wp bug report https://core.trac.wordpress.org/ticket/9716#comment:21 which seems to indicate that the combo of browser and wp plugin editor.

    Anyway in a nutshell, nothing that I can see to update. I suggest deleting the plugin and re-adding from wordpress.

    If warning still occurs, then If you have a local editor that shows line endings and can see a line that is not consistent with others, let me know.
    If it’s sorted then please let me know that too.
    Thanks

    appendix: I develop on windows so my endings are all CRLF (\r\n).

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.