Support » Plugin: Gravity Forms Salesforce Add-on » PHP 7 Support

  • Ran WP Engine’s PHP 7 Compatibility Checker and got two warnings for the Gravity Forms Salesforce Add-on. Any suggestions? Does the add-on/plug-in support PHP 7?

    FILE …/gravity-forms-salesforce/lib/Force.com-Toolkit-for-PHP/soapclient/SforceEnterpriseClient.php
    —————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————–
    41 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    —————————————————————————————–

    FILE…gravity-forms-salesforce/lib/Force.com-Toolkit-for-PHP/soapclient/SforcePartnerClient.php
    —————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————–
    77 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    —————————————————————————————–

Viewing 2 replies - 1 through 2 (of 2 total)
  • Just wanted to add that I’m getting PHP notices using PHP7 because of the old style constructors:

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; SforcePartnerClient has a deprecated constructor in /var/www/…/plugins/gravity-forms-salesforce/lib/Force.com-Toolkit-for-PHP/soapclient/SforcePartnerClient.php on line 74

    Also received those compatibility warnings. Is anyone running the plugin on PHP7 error free?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘PHP 7 Support’ is closed to new replies.