Support » Plugin: WooCommerce - Store Exporter » PHP 7 Support

  • Resolved natalisilverio

    (@natalisilverio)


    Plugin version Version: 2.1.10
    WooCommerce version 2.6.9
    WordPress version 4.6.1

    I performed a check using PHP Compatibility checker and I got the following errors. I would like to know if PHP7 support will be available in the next release of if is there any fix for the issues.

    FILE: /Users/natalisilverio/Sites/crowdyhouse/crowdyhouse-github/wp-content/plugins/woocommerce-store-exporter-deluxe/classes/PHPExcel/CachedObjectStorage/SQLite.php
    ———————————————————————————————————————————————————————
    FOUND 9 ERRORS AFFECTING 9 LINES
    ———————————————————————————————————————————————————————
    63 | ERROR | Extension ‘sqlite’ is removed since PHP 5.4
    64 | ERROR | Extension ‘sqlite’ is removed since PHP 5.4
    108 | ERROR | Extension ‘sqlite’ is removed since PHP 5.4
    142 | ERROR | Extension ‘sqlite’ is removed since PHP 5.4
    166 | ERROR | Extension ‘sqlite’ is removed since PHP 5.4
    211 | ERROR | Extension ‘sqlite’ is removed since PHP 5.4
    236 | ERROR | Extension ‘sqlite’ is removed since PHP 5.4
    274 | ERROR | Extension ‘sqlite’ is removed since PHP 5.4
    276 | ERROR | Extension ‘sqlite’ is removed since PHP 5.4
    ———————————————————————————————————————————————————————

    FILE: /Users/natalisilverio/Sites/crowdyhouse/crowdyhouse-github/wp-content/plugins/woocommerce-store-exporter-deluxe/classes/PHPExcel/Calculation/Database.php
    —————————————————————————————————————————————————————————–
    FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
    —————————————————————————————————————————————————————————–
    67 | WARNING | Method name “PHPExcel_Calculation_Database::__fieldExtract” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    98 | WARNING | Method name “PHPExcel_Calculation_Database::__filter” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    —————————————————————————————————————————————————————————–

    FILE: /Users/natalisilverio/Sites/crowdyhouse/crowdyhouse-github/wp-content/plugins/woocommerce-store-exporter-deluxe/classes/PHPExcel/Shared/PCLZip/pclzip.lib.php
    ——————————————————————————————————————————————————————-
    FOUND 2 ERRORS AND 1 WARNING AFFECTING 3 LINES
    ——————————————————————————————————————————————————————-
    215 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    5347 | ERROR | Function set_magic_quotes_runtime() is deprecated since PHP 5.3 and removed since PHP 7.0
    5378 | ERROR | Function set_magic_quotes_runtime() is deprecated since PHP 5.3 and removed since PHP 7.0
    ——————————————————————————————————————————————————————-

    FILE: /Users/natalisilverio/Sites/crowdyhouse/crowdyhouse-github/wp-content/plugins/woocommerce-store-exporter-deluxe/exporter-deluxe.php
    —————————————————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————————————————————–
    203 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    —————————————————————————————————————————————–

    FILE: /Users/natalisilverio/Sites/crowdyhouse/crowdyhouse-github/wp-content/plugins/woocommerce-store-exporter-deluxe/includes/cron.php
    —————————————————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————————————————————
    237 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    —————————————————————————————————————————————

    FILE: /Users/natalisilverio/Sites/crowdyhouse/crowdyhouse-github/wp-content/plugins/woocommerce-store-exporter-deluxe/includes/settings.php
    ——————————————————————————————————————————————-
    FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
    ——————————————————————————————————————————————-
    1 | WARNING | File has mixed line endings; this may cause incorrect results
    152 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    ——————————————————————————————————————————————-

    Thank you

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Michael Visser

    (@visser)

    Hi natalisilverio, thanks for raising this. Can you please submit this via Support for the Pro Plugin as this support forum is limited to the free offering.

    https://www.visser.com.au/premium-support/

    Plugin Author Michael Visser

    (@visser)

    Hi @natalisilverio, just clarifying for posterity we use the PHPExcel library for generating some file formats in the Pro Plugin, the free Plugin does not use PHPExcel.

    – One of the caching modules that PHPExcel supports is SQLLite which is no longer supported since 5.4, it is not enabled by default and is provided for older hosts.
    – There is a conditional check for set_magic_quotes_runtime before it is run, ZipArchive is used by default with the alternate PCLZip library available where ZipArchive is not.

    Thanks for taking the time to raise this 🙂

    Theo

    (@heytheo)

    Hi @visser,

    Just a follow up to the above, are WooCommerce – Store Exporter free and pro versions now PHP 7 compatible? From what version onwards? Thanks.

    Plugin Author Michael Visser

    (@visser)

    Hi @heytheo, I’ll be confirming PHP 7.1 compatibility for both Plugins today, I’m running 7.1 on some of my development sites and haven’t noticed anything but I’ll do a full review and confirm here then update the readme.txt 🙂

    I’m running version 1.9 but couldn’t see it says “PHP7 compatible” in readme.txt.
    I’m using WP 4.7.5/ PHP 5.6.
    I ran PHP Compatibility Checker and am still seeing some warnings.

    FILE: /home/coms58/public_html/stage/wp-content/plugins/woocommerce-exporter/templates/admin/tabs-settings.php
    ——————————————————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ——————————————————————————————————————————————–
    83 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    ——————————————————————————————————————————————–

    FILE: /home/coms58/public_html/stage/wp-content/plugins/woocommerce-exporter/templates/admin/woo-admin_ce-export_settings.php
    ———————————————————————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ———————————————————————————————————————————————————–
    75 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    ———————————————————————————————————————————————————–

    FILE: /home/coms58/public_html/stage/wp-content/plugins/woocommerce-exporter/exporter.php
    ———————————————————————————————————————–
    FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
    ———————————————————————————————————————–
    149 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    323 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    ———————————————————————————————————————–

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘PHP 7 Support’ is closed to new replies.