Support » Plugin: WP RSS Aggregator » PHP 7 Errors and Warnings

  • Resolved zachwtx

    (@zachwtx)


    We are upgrading our sites to run on PHP 7 servers and the following errors prevent us from doing so while using this plugin. Could the developers please address these errors?

    FILE: wp-rss-aggregator/includes/system-info.php
    ————————————————————————————————————–
    FOUND 2 ERRORS AND 1 WARNING AFFECTING 3 LINES
    ————————————————————————————————————–
    81 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    244 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    246 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    ————————————————————————————————————–

    FILE: wp-rss-aggregator/includes/Aventura/Wprss/Core/DataObject.php
    ——————————————————————————————————————————————————
    FOUND 0 ERRORS AND 3 WARNINGS AFFECTING 3 LINES
    ——————————————————————————————————————————————————
    387 | WARNING | Method name “DataObject::__toArray” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    443 | WARNING | Method name “DataObject::__toXml” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    488 | WARNING | Method name “DataObject::__toJson” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    ——————————————————————————————————————————————————

    FILE: wp-rss-aggregator/includes/libraries/php-markdown/markdown.php
    ——————————————————————————————————————
    FOUND 2 ERRORS AND 2 WARNINGS AFFECTING 4 LINES
    ——————————————————————————————————————
    242 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    1694 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    2271 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    2277 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    ——————————————————————————————————————

    FILE: wp-rss-aggregator/includes/libraries/browser.php
    —————————————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————————-
    225 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    —————————————————————————————————-

    FILE: wp-rss-aggregator/includes/feed-access.php
    ————————————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————————————-
    411 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    ————————————————————————————————-

    FILE: wp-rss-aggregator/includes/opml-importer.php
    —————————————————————————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————————————————————————————
    48 | WARNING | Method name “WPRSS_OPML_Importer::__contruct” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    —————————————————————————————————————————————————————

Viewing 1 replies (of 1 total)
  • Plugin Support Eric Gunawan

    (@erricgunawan)

    Hi @zachwtx,

    We have run tests since the 4.11.1 version of WP RSS Aggregator on PHP 5.6 and 7.x.

    So far, we have found no major compatibility issues. There are no major plugin breaking issues and no visible breakages to the functionality with both PHP 5.6 and 7.x

    However, should you encounter one while setting up or using our Core plugin in the said platforms, we welcome any feedback you may have.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.