• Resolved goodereader

    (@goodereader)


    There are numerous errors with this plugin running a modern version of PHP.

    FILE: /home/goodread/public_html/blog/wp-content/plugins/powerpress/powerpressadmin.php
    ————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————————————–
    3411 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    ————————————————————————————————–

    FILE: /home/goodread/public_html/blog/wp-content/plugins/powerpress/getid3/getid3.lib.php
    ————————————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————————————-
    614 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    ————————————————————————————————-

    FILE: /home/goodread/public_html/blog/wp-content/plugins/powerpress/getid3/getid3.php
    ————————————————————————————————–
    FOUND 0 ERRORS AND 4 WARNINGS AFFECTING 4 LINES
    ————————————————————————————————–
    146 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    150 | WARNING | INI directive ‘mbstring.func_overload’ is deprecated since PHP 7.2
    151 | WARNING | INI directive ‘mbstring.func_overload’ is deprecated since PHP 7.2
    1352 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    ————————————————————————————————–

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Shawn Thorpe

    (@shawnogordo)

    I’ve asked the Blubrry dev team to look at your post. A response will be posted here as soon as they’ve had a chance to do so.

    Plugin Author Angelo Mandato

    (@amandato)

    Hello @goodereader,

    Thanks for reporting the compatibility issues.

    Did you run a script before hand in PHP various versions 5.6, 7, 7.1 and 7.2, 7.3? I wonder where you got these results as they do not appear when testing in these versions.

    For example “3411 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4”, if you go to that line in PowerPress, we first check the php version is less than 5.3 before executing the “safe_mode” check. This is for backwards compatibility.

    The issues with the file getid3/getid3.php should also should not be an issue, when tested in PHP7.2 or even PHP 5.6 the call to ini_get(‘safe_mode’) will return false as the safe_mode setting is not present. I suspect what ever is checking this is not actually running the code in versions of PHP but rather looking for strings and determining that is a problem if it sees the string value “safe_mode”.

    More details where you got your results would be helpful.

    Thanks,
    Angelo

    Plugin Author Angelo Mandato

    (@amandato)

    I’ve been investigating the specific error messages and I believe these results are from the “PHP Compatibility Checker” plugin. If that is the case, please read their warning:

    Please note that linting code is not perfect. This plugin cannot detect unused code-paths that might be used for backwards compatibility, and thus might show false positives.

    In the cases you noted, code is in place for backwards compatibility. In the getid3 library there are also no concerns as it only checks that safe_mode is off, which in newer versions it will always be off, which is good.

    In other words, if you are using “PHP Compatibility Checker” plugin to check PowerPress, these are false positives.

    As of the current PowerPress 7.4.x branch, it is compatible with PHP versions 5.2 through 7.3. In September we will be doing testing with PHP 7.4 (2 months before the release). From what we have read following the changelog we do not foresee PowerPress having compatibility issues with PHP 7.4 in November. If there are issues though rest assured we will fix them.

    Thanks,
    Angelo

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP 7+ errors’ is closed to new replies.