Support » Plugin: WP RSS Aggregator » PHP 7 compatible?

Viewing 15 replies - 1 through 15 (of 19 total)
  • Hi Eric,

    To be honest, we haven’t fully tested WP RSS Aggregator with PHP 7. So we can’t give you any guarantee regarding this.

    If you feel adventurous, you can go ahead upgrade to PHP 7. WP RSS Aggregator is built to follow PHP standard and latest convention, so there shouldn’t be any critical problems.

    But should you find any issues, please report it back to us here. We’ll be happy to help you the best we can, as supporting PHP 7 lies indeed on our roadmap.

    Hope this explains.

    I ran the PHP compatibility checker by WPEngine
    https://wordpress.org/plugins/php-compatibility-checker/

    And it did fail their php 7 test. Hopefully this is something that could be looked into soon. I love this plugin and looking to go to 7 in the near future. Just starting to do my homework on what passes and doesn’t.

    `FILE: /wp-rss-aggregator/includes/system-info.php
    ——————————————————————————————————————————————-
    FOUND 3 ERRORS AFFECTING 3 LINES
    ——————————————————————————————————————————————-
    81 | ERROR | INI directive ‘safe_mode’ is deprecated from PHP 5.3 and forbidden from PHP 5.4.
    244 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and deprecated since PHP 5.6 and removed since PHP 7.0 – use mysqli instead.
    246 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and deprecated since PHP 5.6 and removed since PHP 7.0 – use mysqli instead.
    ——————————————————————————————————————————————-

    FILE: /wp-rss-aggregator/includes/libraries/browser.php
    ——————————————————————————————————————–
    FOUND 1 ERROR AFFECTING 1 LINE
    ——————————————————————————————————————–
    1065 | ERROR | Deprecated PHP4 style constructor are not supported since PHP7
    ——————————————————————————————————————–

    FILE: /wp-rss-aggregator/includes/libraries/php-markdown/markdown.php
    ———————————————————————————————————————————-
    FOUND 4 ERRORS AFFECTING 4 LINES
    ———————————————————————————————————————————-
    1666 | ERROR | Deprecated PHP4 style constructor are not supported since PHP7
    2271 | ERROR | Using a call-time pass-by-reference is prohibited since php 5.4
    2277 | ERROR | Using a call-time pass-by-reference is prohibited since php 5.4
    2828 | ERROR | Deprecated PHP4 style constructor are not supported since PHP7
    ———————————————————————————————————————————-

    FILE: /wp-rss-aggregator/includes/feed-access.php
    ————————————————————————————————————–
    FOUND 1 ERROR AFFECTING 1 LINE
    ————————————————————————————————————–
    261 | ERROR | INI directive ‘safe_mode’ is deprecated from PHP 5.3 and forbidden from PHP 5.4.
    ————————————————————————————————————–

    FILE: /wp-rss-feed-to-post/includes/wprss-ftp-utils.php
    ——————————————————————————————————————–
    FOUND 1 ERROR AFFECTING 1 LINE
    ——————————————————————————————————————–
    155 | ERROR | preg_replace() – /e modifier is forbidden in PHP 7.0
    ——————————————————————————————————————–

    Hi Eric Gunawan,

    It’s important for you guys to make sure it is compatible because WordPress will bump recommended PHP version from 5.6 to 7.0 by the middle of 2017.

    Hi jeffmace,

    We’re really thank you for running this test. We’ll make sure to bring this result to our developers.

    And thanks Eric for noticing about the PHP recommendation for WordPress in the near future.

    For both of you, if you have more to discuss regarding this PHP 7 compatibility (i.e. urgent request, quick fix, etc.), you are free to open a premium support ticket.

    We’ll be happy to accept any feedbacks for this matter.

    Thanks again for both of you, jeffmace and Eric.

    Ubuntu 16.04 uses PHP7.0 by default, and Ubuntu 14 is no longer supported, so I’ve had to upgrade. Now I get no new feed items, which I suspect is due to the lack of PHP7.0 support.

    How do we go about getting this fixed?

    Hi @rbutterworth,

    PHP 7 supports for WP RSS Aggregator is currently under development and planned for a future update although we have no time-frame on its planning as yet.

    If you have any error logs regarding PHP 7 supports, please don’t hesitate to send it to us here. It’ll surely help with the development. Thanks!

    following this too

    following this too

    Following this, any updates @erricgunawan

    Hi @sampohaavisto,

    We’ve started some testing but haven’t covered every aspect. We do not yet have a date for when this will be completed.

    Thanks for asking.

    Just wanted to add the compatibility errors with PHP 7 found on my site. Thanks!

    FILE: ***/libraries/php-markdown/markdown.php
    ——————————————————————————————————————
    FOUND 2 ERRORS AND 2 WARNINGS AFFECTING 4 LINES
    ——————————————————————————————————————
    242 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    1694 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    2271 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    2277 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    ——————————————————————————————————————

    FILE: ***/libraries/browser.php
    —————————————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————————-
    225 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    —————————————————————————————————-

    Thanks @planetregin!

    Turan

    (@turansadrigmailcom)

    Hi,

    Any news on this? Currently this is the only plugin we use not compatible with PHP7 thus preventing us from updating.

    Thanks in advance,
    Turan

    • This reply was modified 2 years, 3 months ago by  Turan.

    Hi Turan,

    While this compatibility issue is still being worked, we have seen that some of our customers are able to use our plugins on PHP 5.5 and above without their functionalities being affected.

    If you’d like to, you can try to run our plugins on PHP7.x in your staging site before upgrading your live/production site. Should you encounter any issues regarding the works of our plugins while you’re testing it, please don’t hesitate to let us know.

    Hi @eric2016, @jeffmace, @rbutterworth, @plumski, @sapu78, @sampohaavisto, @planetregin, @turansadrigmailcom, and all those who happen to arrive at here,

    We’d like to inform you that we have run tests for the current version of WP RSS Aggregator (4.11.1) on PHP 5.6 and 7.x.

    So far, we have found no major compatibility issues. There are no major plugin breaking issues and no visible breakages to the functionality with both PHP 5.6 and 7.x

    However, should you encounter one while setting up or using our Core plugin in the said platforms, we welcome any feedback you may have.

    Thanks again for staying with us and always using the latest version of WP RSS Aggregator. Please don’t hesitate to reach out to us if you need any assistance.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘PHP 7 compatible?’ is closed to new replies.