Support » Plugin: Cimy Swift SMTP » PHP 7 Compatibilty

  • Resolved ZaGenie

    (@zagenie)


    Thanks for a great plugin.

    We’d like to keep using it through to PHP 7.

    However, when checking compatibility with this >> https://wordpress.org/plugins/php-compatibility-checker/

    The warnings below are displayed.

    Are you considering making the plugin fully PHP 7 compliant?

    Many thanks! Herby

    FILE: /home//public_html/wp-content/plugins/cimy-swift-smtp/Swift/lib/classes/Swift/KeyCache/DiskKeyCache.php
    —————————————————————————————————————————-
    FOUND 4 ERRORS AFFECTING 4 LINES
    —————————————————————————————————————————-
    180 | ERROR | INI directive ‘magic_quotes_runtime’ is deprecated since PHP 5.3 and removed since PHP 5.4
    187 | ERROR | INI directive ‘magic_quotes_runtime’ is deprecated since PHP 5.3 and removed since PHP 5.4
    207 | ERROR | INI directive ‘magic_quotes_runtime’ is deprecated since PHP 5.3 and removed since PHP 5.4
    213 | ERROR | INI directive ‘magic_quotes_runtime’ is deprecated since PHP 5.3 and removed since PHP 5.4
    —————————————————————————————————————————-

    FILE: /home//public_html/wp-content/plugins/cimy-swift-smtp/Swift/lib/classes/Swift/ByteStream/FileByteStream.php
    ——————————————————————————————————————————–
    FOUND 2 ERRORS AFFECTING 2 LINES
    ——————————————————————————————————————————–
    87 | ERROR | INI directive ‘magic_quotes_runtime’ is deprecated since PHP 5.3 and removed since PHP 5.4
    91 | ERROR | INI directive ‘magic_quotes_runtime’ is deprecated since PHP 5.3 and removed since PHP 5.4
    ——————————————————————————————————————————–

    FILE: /home//public_html/wp-content/plugins/cimy-swift-smtp/Swift/lib/classes/Swift/Transport/Esmtp/Auth/NTLMAuthenticator.php
    ———————————————————————————————————————————————
    FOUND 1 ERROR AFFECTING 1 LINE
    ———————————————————————————————————————————————
    526 | ERROR | Bitwise shifts by negative number will throw an ArithmeticError in PHP 7.0
    ———————————————————————————————————————————————

    FILE: /home//public_html/wp-content/plugins/cimy-swift-smtp/Swift/lib/classes/Swift/Transport/SimpleMailInvoker.php
    ———————————————————————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ———————————————————————————————————————————-
    33 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    ———————————————————————————————————————————-

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Marco Cimmino

    (@cimmo)

    I just released v3.0.0 of the plugin, supports PHP 7+ and WordPress 4+
    Let me know if this solves your issue.

    Marco

    Thread Starter ZaGenie

    (@zagenie)

    Hello Marco,

    There appears to be one error to go, before 100% compatibiity…

    FILE: /home/public_html/wp-content/plugins/cimy-swift-smtp/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/Esmtp/Auth/NTLMAuthenticator.php
    ———————————————————————————————————————————————————————-
    FOUND 1 ERROR AFFECTING 1 LINE
    ———————————————————————————————————————————————————————-
    526 | ERROR | Bitwise shifts by negative number will throw an ArithmeticError in PHP 7.0
    ————————————————————————————————

    The above is reported by this tool >> https://en-gb.wordpress.org/plugins/php-compatibility-checker/

    Hope this helps.

    Herby

    Plugin Author Marco Cimmino

    (@cimmo)

    It is actually a false positive from the tool you are using, see this bug report:
    https://github.com/wimg/PHPCompatibility/issues/294

    Plugin Author Marco Cimmino

    (@cimmo)

    The plugin is now 100% PHP7 compatible and I’ll consider this issue resolved.
    Thank you.

    Thread Starter ZaGenie

    (@zagenie)

    Thanks Marco. All good.

    Herby

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘PHP 7 Compatibilty’ is closed to new replies.