Support » Plugin: WooCommerce Colors » PHP 7 Compatibility Issues

  • Hello… I am upgrading to PHP 7 and I cannot use your plugin due to multiple errors. I am attaching the errors being thrown from your plugin below. Can you please address these and release an update so that I can use your plugin with PHP 7?

    ERRORS:

    FILE: /www/pilotnick_343/public/wp-content/plugins/woocommerce-colors/includes/libs/class-scss.php
    ————————————————————————————————————————————
    FOUND 4 ERRORS AFFECTING 4 LINES
    ————————————————————————————————————————————
    3449 | ERROR | ‘string’ is a reserved keyword introduced in PHP version 7.0 and cannot be invoked as a function (T_STRING)
    3647 | ERROR | Function name, class name, namespace name or constant name can not be reserved keyword ‘string’ (since version 7.0)
    3760 | ERROR | ‘string’ is a reserved keyword introduced in PHP version 7.0 and cannot be invoked as a function (T_STRING)
    4011 | ERROR | ‘string’ is a reserved keyword introduced in PHP version 7.0 and cannot be invoked as a function (T_STRING)
    ————————————————————————————————————————————

    https://wordpress.org/plugins/woocommerce-colors/

  • The topic ‘PHP 7 Compatibility Issues’ is closed to new replies.