Support » Plugin: Download Monitor » PHP 7 Compatibility

  • Resolved thegoodgroupinc

    (@thegoodgroupinc)


    Hello,

    I would like to upgrade to PHP 7, but my host will not allow me because your plugin won’t pass the PHP Compatibility Checker. Here is the output… can you please reply and let us know if you’ll be updating the plugin to support PHP 7, or not?

    Thank you!

    FILE: /nas/content/live/xxxxx/wp-content/plugins/download-monitor/includes/admin/uaparser/lib/spyc-0.5/spyc.php
    —————————————————————————————————————————————————
    FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
    —————————————————————————————————————————————————
    393 | WARNING | Method name “Spyc::__load” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    398 | WARNING | Method name “Spyc::__loadString” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    —————————————————————————————————————————————————

    FILE: /nas/content/live/xxxxx/wp-content/plugins/download-monitor/includes/class-dlm-download-handler.php
    ———————————————————————————————————–
    FOUND 1 ERROR AND 1 WARNING AFFECTING 2 LINES
    ———————————————————————————————————–
    532 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    537 | ERROR | Function set_magic_quotes_runtime() is deprecated since PHP 5.3 and removed since PHP 7.0
    ———————————————————————————————————–

    FILE: /nas/content/live/xxxxx/wp-content/plugins/download-monitor/download-monitor.php
    ———————————————————————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ———————————————————————————————————————————————————
    38 | WARNING | Function name “__download_monitor_main” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    ———————————————————————————————————————————————————

    FILE: /nas/content/live/xxxxx/wp-content/plugins/download-monitor/installer-functions.php
    ——————————————————————————————————————————————————————-
    FOUND 0 ERRORS AND 3 WARNINGS AFFECTING 3 LINES
    ——————————————————————————————————————————————————————-
    13 | WARNING | Function name “__download_monitor_install” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    65 | WARNING | Function name “__download_monitor_mu_new_blog” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    90 | WARNING | Function name “__download_monitor_mu_delete_blog” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    ——————————————————————————————————————————————————————-

Viewing 3 replies - 1 through 3 (of 3 total)
  • I have the same issue with not being able to update to php 7. Since this plugin hasn’t been updated in 4 months, and they haven’t responded to you in 3 weeks, and the plugin is not 4.7 compatible, I and going to look for an alternate solution even though I love the plugin.

    [added comment] I just reran the compatibility check at wpengine and now it says it is compatible.
    I’m running version 1.9.5.

    • This reply was modified 2 years, 6 months ago by  csasser. Reason: reran compatibility test at wpengine

    edit: Reworking kinks, maybe on my end..

    • This reply was modified 2 years, 6 months ago by  ciordia9.
    Plugin Contributor Harish Chouhan

    (@hchouhan)

    Hello everyone,

    Our plugin is compatible with PHP7. Our development environment is using PHP7. Since our plugin is backward compatible with older versions of PHP a compatibility check plugin such as WP Engine’s will show warnings. You can safely ignore them.
    A better way to check for errors would be to enable WordPress debugging and checking the debug-log file.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP 7 Compatibility’ is closed to new replies.