Support » Plugin: Google Pagespeed Insights » PHP 7 Compatibility

  • Resolved Storyman

    (@storyman)


    Just ran WP Engine’s ‘PHP Compatibility Checker’ and found issues with PHP 7. Here is what it reports:

    FOUND 1 ERROR AND 1 WARNING AFFECTING 2 LINES
    —————————————————————————————————-
    21 | ERROR | Use of deprecated PHP4 style class constructor is not supported since PHP 7
    543 | WARNING | INI directive ‘safe_mode’ is deprecated from PHP 5.3 and forbidden from PHP 5.4.
    ———————-

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Matt Keys

    (@mattkeys)

    Thanks for the heads up. I have been working on and off on a major update to this plugin and PHP 7 compatibility is on my list.

    It has been slower going than I want to as work has been really busy recently, but still hoping to get it out this year.

    Can’t you just put out a minor version and just change the core.php constructor function to __construct.

    I really want to use this. But now I can’t because of just this simple error.

    Plugin Author Matt Keys

    (@mattkeys)

    Hey Danny,

    I wasn’t planning on doing a minor release, but I think your point is well made and the new version is taking longer than I thought it would.

    I am working on a minor release right now to fix a couple PHP 7 errors that I will try to get out today.

    Thanks for your feedback.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP 7 Compatibility’ is closed to new replies.