Support » Plugin: SSH SFTP Updater Support » PHP 7 Compatibility

  • During WordPress Update mails, I have started getting these notices

    Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; WP_Filesystem_SSH2 has a deprecated constructor in /var/www/html/nspeaks/wp-content/plugins/ssh-sftp-updater-support/class-wp-filesystem-ssh2.php on line 23<br />
    <br />
    Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; Net_SFTP has a deprecated constructor in /var/www/html/nspeaks/wp-content/plugins/ssh-sftp-updater-support/phpseclib/Net/SFTP.php on line 127<br />
    <br />
    Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; Net_SSH2 has a deprecated constructor in /var/www/html/nspeaks/wp-content/plugins/ssh-sftp-updater-support/phpseclib/Net/SSH2.php on line 152<br />
    <br />
    Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; Crypt_RSA has a deprecated constructor in /var/www/html/nspeaks/wp-content/plugins/ssh-sftp-updater-support/phpseclib/Crypt/RSA.php on line 273<br />
    <br />
    Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; Crypt_Hash has a deprecated constructor in /var/www/html/nspeaks/wp-content/plugins/ssh-sftp-updater-support/phpseclib/Crypt/Hash.php on line 82<br />
    <br />
    Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; Math_BigInteger has a deprecated constructor in /var/www/html/nspeaks/wp-content/plugins/ssh-sftp-updater-support/phpseclib/Math/BigInteger.php on line 176<br />
    <br />
    Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; Crypt_Base has a deprecated constructor in /var/www/html/nspeaks/wp-content/plugins/ssh-sftp-updater-support/phpseclib/Crypt/Base.php on line 125<br />
    <br />
    Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; Crypt_Rijndael has a deprecated constructor in /var/www/html/nspeaks/wp-content/plugins/ssh-sftp-updater-support/phpseclib/Crypt/Rijndael.php on line 128<br />

    I am using PHP 7.

    https://wordpress.org/plugins/ssh-sftp-updater-support/

Viewing 4 replies - 1 through 4 (of 4 total)
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.